Tekkit is a joke but my FPS was Higher

Status
Not open for further replies.

BlueNuke

New Member
Jul 29, 2019
6
0
0
My computer is less than a year old. I have 700 gb of free space on my HD, 6 gb of ram 1.50 is dedicated to the FTB pack. I have a dual core i7 Pentium. I have changed the priority level for java to High in my task manager, I added optifine to the jar folder and set render distance to tiny, max fps, and everything as fast as I could. The FPS is very choppy it dives to 8 and 10 then back to 20 and sometimes 35 or 40. I am not using a texture pack. I can not stand Tekkit but my FPS was never that low and defiantly not jumping up and down so drastically. I used to use a 64bit sphax texture pack I built from the forums. I understand that this is beta and I am open to suggestions on how to make Minecraft run faster. I'm not yelling or angry just confused as to how everything is running so slowly.
 

John1744

New Member
Jul 29, 2019
3
0
0
My computer isn't anywhere as good as yours but I'm also having the same issue. I can run Tekkit at 40-60 FPS even with 128x Sphax textures. But with FtB with vanilla textures I'm only getting a few FPS at a time, no matter what I seem to do. No idea why there is such a difference. I'm not home but I'll try to post a thread with my log files etc later.
 

John1744

New Member
Jul 29, 2019
3
0
0
I'm not sure about nuke, but I am not, I'm running an AMD Athlon X2 3800+, 4gigs of ram and radeon 5770. I'm also running Windows 8. I just reinstalled Java (the 64bit version)

I think I read on the reddit to maybe completely delete all versions of Java... If you have 6&7 installed there may be issues with the launcher. I'll try that when I get home.
 

Ebr1th1l

New Member
Jul 29, 2019
1
0
0
The only possible thing I can think of that could possibly slow you down is your Processor - and what optifine are you using? Certain versions work better than others, regardless your specs.
(I've got a six core 5.0Ghz, and the multicore optifine makes my fps go from 200 to about 15.)
 

LazDude2012

New Member
Jul 29, 2019
169
0
0
My computer is less than a year old. I have 700 gb of free space on my HD, 6 gb of ram 1.50 is dedicated to the FTB pack. I have a dual core i7 Pentium. I have changed the priority level for java to High in my task manager, I added optifine to the jar folder and set render distance to tiny, max fps, and everything as fast as I could. The FPS is very choppy it dives to 8 and 10 then back to 20 and sometimes 35 or 40. I am not using a texture pack. I can not stand Tekkit but my FPS was never that low and defiantly not jumping up and down so drastically. I used to use a 64bit sphax texture pack I built from the forums. I understand that this is beta and I am open to suggestions on how to make Minecraft run faster. I'm not yelling or angry just confused as to how everything is running so slowly.
Your answer is this: Tekkit includes Optifine, whereas FTB does not. Optifine is known to increase FPS massively (although it causes a couple of render bugs with large frame contraptions) on most hardware.
 

Flip

New Member
Jul 29, 2019
59
0
0
Your answer is this: Tekkit includes Optifine, whereas FTB does not. Optifine is known to increase FPS massively (although it causes a couple of render bugs with large frame contraptions) on most hardware.
OP says he is using optifine with FTB.

I'd suggest deactivating mods one by one and see if there's a particular one causing a problem. If it is happening in a fresh world, start with NEI and mods that have worldgen.
 

Ashzification

New Member
Jul 29, 2019
7,425
1
0
My computer is less than a year old. I have 700 gb of free space on my HD, 6 gb of ram 1.50 is dedicated to the FTB pack. I have a dual core i7 Pentium. I have changed the priority level for java to High in my task manager, I added optifine to the jar folder and set render distance to tiny, max fps, and everything as fast as I could. The FPS is very choppy it dives to 8 and 10 then back to 20 and sometimes 35 or 40. I am not using a texture pack. I can not stand Tekkit but my FPS was never that low and defiantly not jumping up and down so drastically. I used to use a 64bit sphax texture pack I built from the forums. I understand that this is beta and I am open to suggestions on how to make Minecraft run faster. I'm not yelling or angry just confused as to how everything is running so slowly.
Didn't read this. Read the title. Read OptiFine, more than once.

Optifine has not given FTB permission to be used in this pack (from my understanding).
This pack is still in it's beta stages.
 

WTFFFS

New Member
Jul 29, 2019
768
0
0
I suspect your answer may lie in the difference between 1.2.5 and 1.4.2, Tekkit is still on 1.2.5 and there was a huge amount of change in base minecraft between the 2.
 
  • Like
Reactions: Cirom and mr_vit

Ashzification

New Member
Jul 29, 2019
7,425
1
0
  • Like
Reactions: Dex Luther

Wabbit

New Member
Jul 29, 2019
443
0
0
If you're running 7, make sure you have Java 7 update 9. My girlfriend had her fps cut to a third (60 to 20) because she had an outdated java. (update 1)
 

DireSwift

New Member
Jul 29, 2019
5
0
0
I reinstalled the latest version of Java 7 x64 and I went from all kinds of issues (not just in MC mind you) and running MC in 20ish framerate with Sphax 128x to 80 fps. No idea how Java got jacked up on my system as I manually do all my updates and had did a fresh install only a few weeks ago but it was running the 32 bit version (and no, I personally didn't install it so still confused on that one unless my 6 yr old managed to do it)
 

Wabbit

New Member
Jul 29, 2019
443
0
0
I reinstalled the latest version of Java 7 x64 and I went from all kinds of issues (not just in MC mind you) and running MC in 20ish framerate with Sphax 128x to 80 fps. No idea how Java got jacked up on my system as I manually do all my updates and had did a fresh install only a few weeks ago but it was running the 32 bit version (and no, I personally didn't install it so still confused on that one unless my 6 yr old managed to do it)
I assume you use chrome?
Sometimes Java decides what's best for your computer based upon the bit type of the browser you use to pick up the download. Chrome being 32bit. It's fooled me a coupe times.

I use Windows 7 Home Premium 64x. Java's at v7 u9 and I use Optifine HD_U_B5 with the last stable build which was in 1.4.2. That typically gave me 70-90ish fps with a few of the graphics settings altered. I only don't know what version they expect us to use now that they've shoehorned an update. They don't design their modpack with mods they don't have permission for in mind. Understandable, but these guys aren't exactly practiced communicators quite yet so it's anyone's guess what the right step to take is.
 

Flip

New Member
Jul 29, 2019
59
0
0
Add in, Optifine has NOT been configured to work with this pack. Thus why it is causing so many problems, for so many people.

Also:
http://forum.feed-the-beast.com/threads/suggest-mods-for-ftb-here.727/
Will Not be Included
OptiFine
No permissions
Not sure what the permission status of OptiFine has to do with this as the OP installed it independently. Also, there's nothing special about FTB as a pack that requires special configuration for OptiFine over someone installing these mods on their own. Bundling a bunch of mods together in what is essentially a custom MultiMC wrapper doesn't create additional rendering stuff to deal with. OptiFine improves my fps significantly in Vanilla 1.4.x, in a heavily modded 1.4.x, and in FTB.
 

Ashzification

New Member
Jul 29, 2019
7,425
1
0
Just going to throw this out there, you maaaay have to spell it out for him.
I decided on removing it.

The configs have been (and still are) "ironed out" essentially. For a very small number of people, it just does not work.
Regardless. It's not in the pack, it's not going to be in the pack (as per information that has so far been provided).
Therefore, if it does not work with the pack, well, sorry. What's in the pack works, and if it doesn't, that's because it's still beta.
 

Wabbit

New Member
Jul 29, 2019
443
0
0
I decided on removing it.

The configs have been (and still are) "ironed out" essentially. For a very small number of people, it just does not work.
Regardless. It's not in the pack, it's not going to be in the pack (as per information that has so far been provided).
Therefore, if it does not work with the pack, well, sorry. What's in the pack works, and if it doesn't, that's because it's still beta.
Though they could point us in the right direction of which version of Optifine would be best to use.
In a better way than just glancing over it in a live stream with several thousand screaming kids.

Communication. The people want it.
 

Ashzification

New Member
Jul 29, 2019
7,425
1
0
Though they could point us in the right direction of which version of Optifine would be best to use.
In a better way than just glancing over it in a live stream with several thousand screaming kids.

Communication. The people want it.
The people can wait. It's beta. Therefore, incomplete. A work in-progress. When it's done, then look for versions of mods that aren't included. That is when you'll find ones that should work. And if they don't, chances are, user error.
 

Flip

New Member
Jul 29, 2019
59
0
0
Yes, please explain why you think OptiFine needs to be specially configured for FTB for it to work. When, 1) it works just fine for many people, improving FPS as it should, and 2) there's nothing special that FTB adds to the process other than an easy method to install mods, all of which work perfectly well with OptiFine, and have since it added built-in Forge compatibility months and months ago.

If the OP is having an issue, and there are people here willing to help him with the issue, why does it matter if it isn't not in the pack? I understand why Slowpoke and the pack authors don't have an obligation to support users in this case, and that's fine. But coming in here and insisting that the user is as fault because he's using a mod not in the pack is flat out wrong, and I believe contradicts the spirit in which this project came together.
 
  • Like
Reactions: Ldog
Status
Not open for further replies.