Unsupported Tech World 2 1.1.x+ Bug Reporting

Discussion in 'Modpack Bugs' started by Jadedcat, Jan 29, 2014.

Thread Status:
Not open for further replies.
  1. Jadedcat

    Jadedcat New Member

    Please note we cant fix a lot of the issues just report them here so we can fix them in future.

    Be sure to send the FTB console log not the minecraft crash report

    Please report all Launcher crashes/ failures here http://forum.feed-the-beast.com/forum/tech-support.14/

    Format:

    Mod Pack: FTBTech World 2
    Mod & Version:
    Pastebin link to crash log:
    Whats the bug?
    Can it be repeated?
    Known Fix:


    New rule for this thread. If you post a bug that's already known and it doesn't provide any more new useful information it will be deleted. Posts that provide no useful information may also be deleted.

    If you post a bug or problem already mentioned here: http://forum.feed-the-beast.com/threads/important-update-news-read-before-updating-any-pack.36499/

    We will delete it. Read the warning thread before posting bug reports.


    Follow the format in the first post and check to see if your bug is known before posting. If your post vanishes its already known or not a bug or didn't include enough info.

    "I has a bug"

    "xyz mod is broken"

    "it crashes" -- with no crash report

    the above do not qualify as bug reports and will be terminated on sight.
     
  2. Loke2

    Loke2 New Member

    Mod Pack: FTBTech World 2 1.1.1
    Mod & Version: RotaryCraft 1.6 V15b
    Pastebin link to crash log: No crash
    Whats the bug? Gearboxes does not display. Gearboxes report wrong type in NEI. Machine power display wrong
    Can it be repeated? Yes
    Known Fix: None

    After updating to TechWorld 1.1.1, existing RotaryCraft installations are bugged. Machines will display no power input, but apparently works anyway. Dynamometer can display "Power: 0W, Torque: 512Nm, Speed 8 krad/s", which is nonsense.
     
  3. Itaros

    Itaros New Member

    Mod Pack: FTBTech World 2
    Mod & Version: FTBTech World 2 1.1.1(General issue after update)
    Pastebin link to crash log: Not a crash
    Whats the bug? Excessive memory stress with short freezes(Used memory goes from 400MB to ~2400MB with a rate of 20MB per tick. After reaching 2,4Gb it drops again to 400MB.) causing massive FPS drop for a short time(GC?)
    Can it be repeated? Yes, always(SSP)
    Known Fix: No(Can be related to RotaryCraft issue above?)
     
    Last edited: Jan 30, 2014
  4. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    If you went through v15, you need to break and replace them.
     
  5. Itaros

    Itaros New Member

    I am currently have latest FTB TechWorld 2(1.1.1) with "RotaryCraft 1.6 V15b" installed(in mods folder) and gearboxes are not rendered properly(invisible with exception of lubricant in them). Breaking them and placing them back again doesn't make them visible. Am I missing something?
     
  6. Loke2

    Loke2 New Member

    Already tried that without any luck. Problems persists even in a completely new world.
     
  7. Itaros

    Itaros New Member

    Mod Pack: FTB Tech World 2
    Mod & Version: RotaryCraft v15b
    Pastebin link to crash log: Not a crash
    Whats the bug? Using jetpack by me(I am hosting using "Open to LAN") causes others players to fly with message spam "Machine/item was deleted before its packet could be received"
    Can it be repeated? Yes
    Known Fix: None

    P.S. There also this spam from RC in console:
    Code:
    2014-01-31 13:23:45 [INFO] [STDOUT] Tile Entity Filling Station @ -160, 39, 333 sent a sync packet from the client! This is not allowed!
    2014-01-31 13:23:45 [INFO] [STDOUT] Tile Entity Filling Station @ -160, 39, 333 sent a sync packet from the client! This is not allowed!
    2014-01-31 13:23:46 [INFO] [STDOUT] Tile Entity Filling Station @ -160, 39, 333 sent a sync packet from the client! This is not allowed!
    What a mess X_X
     
  8. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    I do not get this error, nor should it be possible. Are you using MCPC or similar?


    Not for me.
    [​IMG]
     
  9. Loke2

    Loke2 New Member

    Tried complete re-install and new world with no dice.

    This is taken from our server. How are these readings even possible? 65.536 kW - Insufficient power, 1 W needed? There is noise from the boring machine, but it won't work (assumably due to insufficient power). Also notice the missing (lubricated) gears.
    [​IMG]

    Is any additional info (config or log) needed? It is possible to repeat on newly installed unaltered FTB TechWorld 2. I understand that this is hard to fix, if it is impossible to recreate on your side (which is odd in itself). But if it will not be looked into any further, it would be nice to know, so that I can remove rotarycraft from our server.
     
  10. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    Are you using DragonAPI v15b, too?
     
  11. Loke2

    Loke2 New Member

    The TechWorld 2 1.1.1 pack has DragonAPI 1.6 V15. Not V15b. I guess that explains it. Hopefully the FTB team will update shortly. Thanks a lot for helping.
     
  12. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    I notified Eyamaz.
     
  13. Jadedcat

    Jadedcat New Member

    Tech World is maintained by me. Update will go out next Thursday.
     
  14. DarkRaven

    DarkRaven New Member

    I hope I'm posting this to the right place. Apologies if I fuzz up.

    I've been running a low-volume (2-3 users max) TechWorld2 server since 2.1.0.1. Upgraded to 2.1.1.1 as soon as it came out.

    While people are using the server, it will crash after a seemingly random amount of time, or simply shut itself down.

    Here's what the log says just as the users are disconnected and the system stops responding:

    At this point, I either have to restart the system because it shut itself down, or kill off the processes manually (kill -9 required, graceful exit requests are ignored) and restart the service.

    It also crashes. The following logs are preceded by excessive memory usage and high CPU loads (230%+)

    Best guess I have is that some chunk is loading with some item in it that's causing it to run away with a memory leak.

    Server options:
    I tried RotaryCraft, but the windmills crash the server on placement. So no-RotaryCraft items are placed.

    I have the following items:
    • 4 Electric Furnace
    • 2 Generators
    • 1 Batbox
    • 1 Metal Former
    • 1 Compressor
    • 1 Ore washer
    • 2 Macerators
    • Bed
    • 4 Barrels
    • Several iron chests
    • Blast Furnace (HLSA, not vanilla steel)
    • Wheat farm
    • Carrots
    • Ender seeds
    • House made of stone bricks & wood stairs
    Even with just my chunks loaded, after a few hours, it will stop working. With 2 people on, it survives less time, but usually no less than 30 minutes.

    It also likes to crash after building nether gates, but that might be coincidental.

    Anyone else reporting a similar issue? Problem with the upgrade from 1.0.1 -> 1.1.1?

    Thanks for your assistance in advance and putting together such an awesome mod pack!
     
  15. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    Can I get a log on that?
     
  16. DarkRaven

    DarkRaven New Member

    Sadly, doesn't seem to say much:

    Immediately after placing Wind Turbine 30890:1

    Strangely enough, when I restarted the server, the turbine was still sitting there, spinning and the system did NOT crash... weeeeird.
     
  17. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    Then it is the placement actions that crashed. I have no idea why that would be the case, as all the engine code does is stuff like set directions and engine type.
     
  18. DarkRaven

    DarkRaven New Member

    Wonder if it has something to do with blade placement. Maybe it's trying to position itself on the block and that logic is borked? I laid it on the ground with 1 side having an edge. Lemme try on top of a block with all sides free[DOUBLEPOST=1391740494][/DOUBLEPOST]Veeeeerrry interesting. It placed successfully at the top of a stack of dirt.
     
  19. Reika

    Reika RotaryCraft Dev FTB Mod Dev

    Which is where it is supposed to be placed (it cannot be placed on flat ground).
     
  20. DarkRaven

    DarkRaven New Member

    One side was open. Still, in this case, I'd say having a placement algo that refused placement is a better idea than crashing the server ;)
     
Thread Status:
Not open for further replies.

Share This Page