SOLVED 1.0.1: server cpu usage

Discussion in 'FTB Presents Direwolf20 1.7.10' started by rubigwill73, Nov 7, 2014.

  1. rubigwill73

    rubigwill73 New Member

    Version:
    1.0.1

    What is the bug:
    after 30 mins of game play/server running even if none one is on the server it will jump from 20% all the way to 90% in the server cpu and stay there until server is restarted. once restarted it gets about another 30 mins of low cpu usage then it jumps back to 90%. This happened on 1.0.0 and 1.0.1.

    Mod & Version:


    Paste.feed-the-beast.com log:


    Can it be repeated:


    Known Fix: It was aroma backup. I disabled it on my server all is well now thx!
     
    Last edited: Nov 11, 2014
  2. The_Damaged

    The_Damaged New Member

    Yeah, pretty sure this is the EnderIO power cables. Cause lag bursts of about 2-3 seconds (best seen when trying to open and close chests). After extensive work today (both myself and other clients of CreeperHost) we narrowed it down to those.

    This of course leaves us with a problem. If we disable them to stop people lagging up servers, what do we suggest people use as an entry-level RF transport? Takes upwards of 10 ender pearls to be able to make Extra Util energy nodes.
     
  3. Solax

    Solax New Member

    We have no EnderIO cables and have the same issue with 1.0.1. Server is still playable, even though capped CPU causes some block lag. Restarting helps.
     
  4. Duo

    Duo New Member

    MFR rednet energy cables are good early for energy transfer, as well. I found them easier to craft than the ender io ones, personally.
     
  5. It_IS_Lupus

    It_IS_Lupus New Member

    Make sure your jre is up to date. Upgrading to Java 8 jre8v25 fixed it for the better part. I upgraded it at about 8 and been running since with no issues.
     
  6. fall1aty

    fall1aty New Member

    I'm pretty sure this is aroma backup i had the same problem with another modpack every time it starts to run a backup the CPU usage stuck at 90-100% and stay there.
     
    rubigwill73 likes this.
  7. Tankh

    Tankh New Member

    Yes I also believe this is AromaBackup.

    It has other issues as well. After the first backup is done (Default is every 30 minutes, which is why you see this happen after 30 minutes uptime) It never does a second update.

    I checked "/Backup Schedule" and got "[Ā§1AromaBackupĀ§r] Next backup in 23593554 minutes."
    I then tried "/Backup schedule set 60" just to increase time between backups, and the server just insta-crashed.
    I will probably disable AromaBackup and instead use my own backup shellscript running outside the minecraft server. You can find the script here if you're interested: http://forum.feed-the-beast.com/threads/ftb-server-backup-script.45637/#post-798681
     
  8. rubigwill73

    rubigwill73 New Member

    thx a ton
     
  9. fall1aty

    fall1aty New Member

    No problem
     
  10. GemSlate

    GemSlate New Member

    I had the same issue. 30 minutes after starting the server, CPU usage would jump from averaging 5-15% to 99-100% until it was restarted (new world, no EnderIO pipes or chunk loaders of any kind). I actually watched this happen as soon as AromaBackup ran.

    The Fix: (other than disable)
    Upgrade your Aroma1997Core and AromaBackup. Seems the versions that download with the server are not the most up to date. Aroma1997Core -1.7.10-1.0.2.9 updates to 1.0.2.12 and AromaBackup-1.7.10-0.0.0.4 updates to 0.0.0.5.

    From the AromaBackup-1.7.10.-0.0.0.5 Change log
    Version 0.0.0.5:
    -Fixed bug with scheduled backups not starting. (This was a SEVERE bug, you may want to update).

    Hope this helps others with the same issue. It seems to have fixed both of my Direwolf20 1.7.10 servers. Now if only I could get Multicraft to see the servers are up and running...
     
  11. Jajujo

    Jajujo New Member

    I tried getting rid of Aroma, removing the ender IO pipes from my base and nothing seemed to help.

    I finally gave opis a shot and found the offending chunk. I started tearing out machines and rerunning opis after each to see when the update time dropped.

    Turns out my major problem was from the Buildcraft Advanced Crafting Table. Removing this one block dropped the update time from 30000+ to 150! Server CPU usage also dropped from nearly 100% to around 30%.
     
  12. bgsteiner

    bgsteiner New Member

    I was able to get my multicraft setup to see my server you just need to add this to your strat script
    -Djline.terminal=jline.UnsupportedTerminal
    and it recognized it perfectly it does add the method that is outputting text to the line so it can be harder to read although
     
  13. poxun

    poxun New Member

    I'd been getting very poor performance on my sever and after replacing Aroma backup with a linux script cron backup and while doing so realising I was running openJVM instead of Oracle Java and therefore switched. Now it runs smooth as silk.
     
  14. GemSlate

    GemSlate New Member

    Finally got Multicraft to see my servers running. I had to make the following addition to the end of my FTBServer.jar.conf file.

    [parse_log]
    start=^(?P<time>:)?[-\d]+ )?\[?[:\d]+\]?)\s+\[?(?P<type>[^]]+)\]\:?\s+:)?\[[^]]+\]\s+)?(?P<line>.*)$

    [parse_connect]
    shortStart=logged in with entity id \d+ at

    [parse_clean]
    start=(^[>\r\s]+|\x1b(\[|\])[0-9;]*m?|\x08)

    Multicraft now sees the server up and running as well as correctly logs the players name online.
     

Share This Page