Railcraft Commercial Steam engine quirks

Discussion in 'Mod Discussion' started by MobiusOne, Jan 10, 2015.

  1. MobiusOne

    MobiusOne Active Member

    So, i have been wondering this for some time, but how do i hook up a commercial steam engine to a power system like so?
    [​IMG]
    My goal is to get the power from this steam engine to run my Buildcraft Lasers to the right, but...
    [​IMG]
    When enabled the engine just builds up power inside itself until it turns orange (then i turn it off, cause don't want to risk blowing up my expensive stuff adjacent to it.

    I have tried hitting it and the wooden conductive pipe with both a wrench and a crowbar, but nothing changes.

    Why is this? What is the easiest workaround so i can power my lasers?
     
  2. Bagman817

    Bagman817 Well-Known Member

    It's a bit difficult to answer without knowing what pack or at least what version of MC you're playing on, but one solution might be to try some other mod's power cable.
     
  3. MobiusOne

    MobiusOne Active Member

    I am on the Direwolf20 1.7.10 pack, sorry about that.
     
  4. Bagman817

    Bagman817 Well-Known Member

    Right, then. For troubleshooting, I'd recommend duplicating your set up on a test world in creative. First thing I'd try is replacing the BC pipes with Ender IO energy conduits. If that works, that would suggest there's an issue with the BC pipes. If it doesn't, try replacing the engines with TE steam dynamos. if none of that works, I'm at a loss.
     
  5. MobiusOne

    MobiusOne Active Member

    Ok, thanks for the help, ill tell you how it goes tomorrow.
     
  6. asiekierka

    asiekierka Over-Achiever Mod Developer

    Update to DW20 1.0.3+
     
  7. Captain_Oats

    Captain_Oats Well-Known Member

    I had a similar problem to yours with industrial steam engines. I tried several tiers of energy conduits (EIO) and it didn't make a difference.

    I found that the internal buffer is now the "heat" of the engine, and in order for the steam engines to produce their stated output, they must be in the red heat zone. In previous versions red meant overheating, now it means it's running at full efficiency. Also they don't explode anymore. So in my example the industrial steam engine would output 30-40 RF/t until it's buffer was full and it reached the "red heat", at which point it would finally output 60 RF/t safely.

    Make sure you're on the latest version of RC/BC, I know engine explosions have been removed. For the steam engines red means good now. For other BC engines red means it's overheating, and after they have been red for some time they will shutdown and require a smack with a wrench in order to resume functioning (again no explosion).
     
    KocLobster and CupcakeNautilus like this.
  8. MobiusOne

    MobiusOne Active Member

    I am on 1.0.2 and it will not seem to get past 6600 stored energy (MJ). This is only the green state. I guess I will just have to try upgrading to the most recent version.
     
  9. MobiusOne

    MobiusOne Active Member

    Ok, the updating worked. I checked the changelog and i believe it was probably the changes to Railcraft with the MJ vs RF api. Thanks for all the help.

    Also, for anyone's reference, The amount of RF needed to be stored is around 132000 for the commercial steam engine before it starts outputting power (RF).
     

Share This Page