NEI cheat mode not working anymore

Discussion in 'Mod Discussion' started by EricBuist, Jul 6, 2014.

  1. EricBuist

    EricBuist Active Member

    Hi,

    After searching for more than half an hour about MFFS multi-tool causing server crash and finding absolutely nothing, I tried to create myself a throw-away single-player world in order to try creating a coercion deriver and destroying it with a multi-tool, to see if the game will crash or not. Well, NEI cheat mode does not come up anymore. Even though NEI is enabled and in Cheat mode, the mode now acts the same way as Recipe mode. These are just way too much bugs now. Each time I am trying something, I am hitting an issue that prevents me from going forward and I need to spend hours and hours searching for a workaround. This started with FTB Monster after I migrated my map and goes on since then. This is just too overwhelming. Mod complexity and unexpected behaviors add up, making things very hard for me. Maybe I chose the wrong mod pack then? What are the people using to play modded Minecraft? Do I really need to downgrade and stay with FTB Unleashed who was working far better? Thanks for any help.
     
  2. trajing

    trajing New Member

    1. Go to where you would normally turn it to cheat mode
    2. Click 'World'
    3. Cheat Mode should have changed to Recipe Mode. Click the W next to it.
    4. If it doesn't work, you did it wrong.
     
    E_DM_B, RedBoss and Padfoote like this.
  3. YX33A

    YX33A New Member

    To explain how I understand the issue: Global mode fucks it up. Go into the NEI options menu and there is a setting for "Global Mode", which does sweet fuck all AFAIK, and "World Mode", which is what you need to be in to change anything.
    ...Unless you disabled in game NEI changing via the NEI config like I did.
     
    RedBoss and Padfoote like this.
  4. EricBuist

    EricBuist Active Member

    Hi,

    I don't see any World and Global options. To change the mode, I pressed E to access inventory, clicked on the Options button at the lower left of the screen, clicked Inventory, then I was able to switch between Recipe, Cheat and utility modes. If I click on the World section, I have only Highlight Tooltips as an option. I also tried this out on the FTB Direwolf20 1.6.4 pack and getting the same issue, so this seems a NEI problem.

    So seems I have to take a break for a few months and wait for all these mods to fix and get back together. Or is NEI open source? I could check the code and try to help fixing, because I like this game and am just pissed off to have to give up because it is way too buggy.
     
  5. trajing

    trajing New Member

    You click on inventory, then you click on world in the top right corner.
    And for the love of {Deity of your choice}, PLEASE stop prefixing everything with "Hi,"!
     
    Gideonseymour and Padfoote like this.
  6. EricBuist

    EricBuist Active Member

    Found it, thanks. I could cheat myself the coercion deriver and shift-right click with the multi-tool. Worked like a charm. So seems something happening only in SMP or only with my map.
     
  7. LukeWUK

    LukeWUK New Member

    Wow did you add yourself as a server admin or 'op'?

    If not dont you think nei would be more broken if everyone could cheat in items than how it is now?
     
  8. Padfoote

    Padfoote Brick Thrower Team Member Forum Moderator

    How is NEI "broken"?
     
  9. trajing

    trajing New Member

    a) He isn't an idiot.
    b) Capitalization. Use it.
     
    Padfoote likes this.
  10. LukeWUK

    LukeWUK New Member

    From the OP sorry, it works great for me! I was assuming it was user error and sounded like the issues I had when first updating my NEI a while ago the old methods from 1.4.7 dont work anymore on SSP, and maybe he hasnt worked with SMP before!

    I was assuming he was on SMP server but hadnt opped himself sorry!, hence the "wow" due to my bad assumption that he was moaning about it not working without thinking it all the way through!
     
  11. FriskyGrub

    FriskyGrub Guest

    Punctuation -- use it.
    Also, could you please -- for the love of {ffs just say god, you aren't being clever} -- stop itemising all of your comments; you look like you're treating OP as an idiot.
    ps - Yep, i revived a necro thread, !AND CREATED AN ACCOUNT! because your attitude is really that annoying (man, I hope you're an active user still)
    pps - No-one cares that you use ruby, it doesn't make you cool
    ppps - god bless

    edit: Ooh May14 last active. There is hope.

    1) No, noone was wondering about your avatar
    b) You're gonna look back at the 'location: Earth, MW, Universe" in your profile in a few years and realise how dumb it sounds.
     
    ICountFrom0 likes this.
  12. Scottly318

    Scottly318 New Member

    A post of the dead! But I would like to correct you while I'm here. His use of "insert deity here" is correct. To say God is implying that the initial poster is Christian which trajing right didn't assume. And you look like ass for this post. Congrats
     
    JaRyCu likes this.

Share This Page