Mac Mysteriously quiet sounds

  • FTB will be shutting down this forum by the end of July. To participate in our community discussions, please join our Discord! https://ftb.team/discord
Status
Not open for further replies.

esotericist

New Member
Jul 29, 2019
93
0
0
So, with my windows machine out of commission temporarily, I decided to load up FTB Ultimate on my mac.

After some fussing with java settings (mostly involving memory bits), it seems to be working fine, except in-game when I interact with stone objects, it's super-quiet; sounds like interacting with wool.

Moreover, the sound you get when you pick up a drop is almost imperceptibly quiet as well.

Conversely, other sounds seem unaffected: interacting with wood, the sound of the chickens outside of my base.

I've tried disabling the integrated soundpack, liteloader in general, and some other things, but I can't find anything that seems to explain it.

Worse, I tried loading up a Lite world... and I had different sound problems; dirt was completely silent.

Nothing obvious stands out in the console.. I've tried F3+S, but that seems to have no effect on the problem.

I've quit and reloaded the game several times, and it's consistently behaving in the above manner..

Can anyone give me any pointers?
 

NashuLee

New Member
Jul 29, 2019
162
0
0
Dude, when you say fussing with Java, can you help me. I am unable to get ultimate to work on my machine. Would you mind sharing what tweeks you made?

Thanks
 

esotericist

New Member
Jul 29, 2019
93
0
0
Sure!

The first thing I had to do to get the launcher to stop bailing out on me was make sure I was running the apple native java 6... Apparently, the oracle java 7 doesn't play nicely with this stuff.

I don't remember offhand how I tracked that down and removed it; when I get a chance to locate the thread, I'll include that here.

The other thing I did was adjust the Advanced Settings for minecraft in the launcher.. Again, I don't have the thread on hand, but here's what I put into the launcher.

Go to the Options tab, click Advanced Options at the bottom, and for Additional Java Parameters, I have:
Code:
-Xms512m -XX:PermSize=128M -XX:MaxPermSize=512m

The case MATTERS for java options, so be sure you get it exact. If you want to C&P into the launcher, java uses ctrl+c, ctrl+v, etc instead of command+c, command+v.

If you're giving minecraft less than 2 GB of ram with the slider, you probably want to change those 512s to 256s. The instructions I remember reading had the 128 the same either way.

Hope this helps. If you need me to find the java 7 thread I'll try to do so when i have more time to dig through my history.

Edit: Fixing silly emoticon issue for posterity.
 

NashuLee

New Member
Jul 29, 2019
162
0
0
Sure!

SNIP.

Sounds good, I had to do the same with the Java, and I have been able to get the launcher to work, but I cant get ultimate to load a world. It freezes at that point

The issue I am having right now is that I cant adjust in the avdnaced settings. When I add any code, it crashes the launcher upon hitting launch. It gives me an error saying
Unrecognized VM option 'permSize=128'
Could not create the Java virtual machine.

I stared a thread looking for help about that and was told to try putting the code in quotes, so I will try that also.

I did not realize why the copy and paste was not working , so that too is great info. I will try this tonight when I get home and the kids are inbed. Thanks!!
 

esotericist

New Member
Jul 29, 2019
93
0
0
Oh, for f--

Okay, part of the problem is the STUPID emoticon nonsense.


Code:
-XX:PermSize=128

The capital P is critical.

Edit: You don't want quotes.
 

esotericist

New Member
Jul 29, 2019
93
0
0
For anyone who might have this problem after me, I found the solution.

The problem, it turns out, is that lwjgl -- the library that Minecraft uses for graphics, sound, and input -- is made out of pure retardium, and pretty much has no bug-free versions; they all suck for someone.

Happily, you don't have to use ALL of a given release of lwjgl. I replaced ONLY the openal.dylib file in my minecraft/bin/natives folder with one from a newer version of lwjgl found on this site (the newest version is 2.8.5, but I used 2.8.4) and all is well.

Replacing ALL of lwjgl with a 2.8.x release got me severe graphical errors. This might be because of the intel integrated graphics on my mac mini, or it might be a deeper problem. Either way, I recommend only replacing the openal.dylib file (ignore the libopenal.dylib in the natives folder) for resolution of this issue.
 

wakafanykai123

New Member
Jul 29, 2019
152
0
0
Dude, when you say fussing with Java, can you help me. I am unable to get ultimate to work on my machine. Would you mind sharing what tweeks you made?

Thanks
You can also fix the java 7 problem by launching the .jar from terminal with a -nojvm or something flag. Maybe -nolwgl. I shall find the correct one ASAP
 
Status
Not open for further replies.