Mystcraft And Railcraft ANd Portals Beware.

  • Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Malkuth

New Member
Jul 29, 2019
314
0
0
Seems we have a nasty little bug where if you use a cart to travel through a Mystcraft portal you will get a nasty little crash.​
So setting up those nice lava runs from the Nether to your Homebase is not a possibilty at this point.​
Not sure if its a mystcraft thing, railcraft thing.. (should not be the cart is minecraft object) or a forge thing.​
Can't update to the newest forge because they seem to be down. But the current forge used in DWP it will happen.. And happen bad. ;)
 

INCSlayer

Well-Known Member
Nov 17, 2012
185
48
53
i think its because of the server unloading the nether dimension when i put a chunk loader in the nether it worked (then again i also updated to the second to latest forge 6.5.0.480 so that might also be it)
 

quaymal

New Member
Jul 29, 2019
4
0
0
Nope it was a railcraft problem. You have to update to the newest version to fix it. ;)
Hey there, same issue. I tried your suggestion, updating both my client and server to 6.12.2.0 by putting the .zip file in both client/server 'mods' folder, no luck. Any other ideas? :(
 

Malkuth

New Member
Jul 29, 2019
314
0
0
Hey there, same issue. I tried your suggestion, updating both my client and server to 6.12.2.0 by putting the .zip file in both client/server 'mods' folder, no luck. Any other ideas? :(
Ya there is an unofficial hotfix in the Mystcraft Thread that actually fixes it until the Mod Author comes back from vacation and fixes it himself. Have not had any isssues since then.

http://www.minecraftforum.net/topic/918541-146-mystcraft-09500/page__st__8300#entry19884006

You have to add the fix to your jar file.. Not in the mod folder by the way. Just use FTB Editor/jar files to load it in.

Same place you put Forge, and Optifine... (Again Won't work in the MODS folder)

Oh And PS... When Mystcraft gets updated don't forget to take that out of the FTB Loader.. Have no idea what it could do if you don't when the fix is finally in... Its important you don't forget this part. :)
 

Sorok

New Member
Jul 29, 2019
15
0
0
This fix worked well for me. However I discovered that with the current version of railcraft, World Anchors aren't working properly when trying to sent carts to different dimension. The other chunkloader works fine though.
 

quaymal

New Member
Jul 29, 2019
4
0
0
Ya there is an unofficial hotfix in the Mystcraft Thread that actually fixes it until the Mod Author comes back from vacation and fixes it himself. Have not had any isssues since then.

http://www.minecraftforum.net/topic/918541-146-mystcraft-09500/page__st__8300#entry19884006

You have to add the fix to your jar file.. Not in the mod folder by the way. Just use FTB Editor/jar files to load it in.

Same place you put Forge, and Optifine... (Again Won't work in the MODS folder)

Oh And PS... When Mystcraft gets updated don't forget to take that out of the FTB Loader.. Have no idea what it could do if you don't when the fix is finally in... Its important you don't forget this part. :)
Awesome - thanks man. Worked perfectly!

This fix worked well for me. However I discovered that with the current version of railcraft, World Anchors aren't working properly when trying to sent carts to different dimension. The other chunkloader works fine though.
Same. The "Chunk Loader" anchor does seem to work while the World Anchor doesn't anymore. No biggy!
 

Malkuth

New Member
Jul 29, 2019
314
0
0
Awesome - thanks man. Worked perfectly!



Same. The "Chunk Loader" anchor does seem to work while the World Anchor doesn't anymore. No biggy!
Remember that in the new version of railcraft Chunck loaders are powered by Ender Pearls by default.. (click on one and you will see a new GUI for it). You can turn it off in the railcraft config file though if you want to change it.. change the number to -1
 

Sorok

New Member
Jul 29, 2019
15
0
0
Remember that in the new version of railcraft Chunck loaders are powered by Ender Pearls by default.. (click on one and you will see a new GUI for it). You can turn it off in the railcraft config file though if you want to change it.. change the number to -1
Not sure if I like that change, personally I feel the chunk loading mechanic isn't something we should have supply more than a block for. Especially after it already cost two diamonds to make one + ender pearls are scarce before you get to the end. I've grown fawn of the 'Chunk loader' anyways. Pretty lasers :D
 

Malkuth

New Member
Jul 29, 2019
314
0
0
Ya I agree I don't understand why he did it either.. But at least you can turn it off.. I feel that chunk loaders fix a flaw in the way minecraft works. Build it, place it forget it.. I still don't have a steady supply of ender pearls.. I never even tried tooo. But now wireless redstone needs it, and some other things. Guess I will have to find the end somewhere... But of course you need enderpearls.. I found 3 or 4 so far in my game.. And 3 of em I used for ender chest.