Low FPS & Spikes while playing Direwolf20 1.7.10

  • Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Kezaraux

New Member
Jul 29, 2019
9
0
1
I am severely confused as to why I would be getting low FPS and fairly consistent spikes while playing this pack on my computer. I'll list everything (that I think is necessary) about my computer and about how I'm running the game.

Computer Specs:
CPU: AMD FX-6300 Six-Core Processor @ 3.50GHz
GPU: AMD R9 270x Gaming Edition (2GB GDDR5 RAM)
RAM: 8GB
OS: Windows 8.1 (64-bit)​
Software:
Java: Version 8 Update 25 (Both 32-bit and 64-bit)
GPU Drivers: Up to date​
Launcher Settings:
RAM Allocated: 3.5GB
JVM Arguments:
Code:
-Xmn2G -Xss4M -Xms4G -Xmx4G -XX:+UseLargePages -XX:+AggressiveOpts -XX:+UseFastAccessorMethods -XX:+OptimizeStringConcat -XX:+UseBiasedLocking -Xincgc -XX:MaxGCPauseMillis=10 -XX:SoftRefLRUPolicyMSPerMB=10000 -XX:+CMSParallelRemarkEnabled -XX:ParallelGCThreads=10 -Djava.net.preferIPv4Stack=true
Arguments taken from this thread here.​
Game Video Settings:
Graphics: Fast
Smooth Lighting: Off
3D Anaglyph: Off
GUI Scale: Normal
Clouds: Off
Fullscreen: Off
Mipmap Levels: Off
Render Distance: 12 Chunks
Max Framerate: 80 FPS
View Bobbing: Off
Brightness: Bright
Particles: Minimal
Use VSync: On
Anisotropic Filtering: Off

Thought to mention, I'm using the default texture pack.​

I am working off of a fresh download, no configs were changed, no mods disabled, removed, or tweaked.
If I'm missing some piece of information above, let me know and I'll add it in.

Anyways, the reason I'm posting this is because I feel that I should be getting MUCH higher frame rates than what I actually am. If I can run Battlefield 4 with every setting at the maxiumum (except Anti-Aliasing, which is at 4x) and get a smooth 55-60 FPS, why do I get a cruddy 20 FPS with consistent spikes on my Minecraft? If someone could explain to me what I'm doing wrong, or some sort of settings I need to tweak in a config, or just in the game itself, I would really appreciate that. I'd like to be able to enjoy playing Minecraft, instead of dreading dealing with the choppiness. Thanks in advance.
 

tedyhere

New Member
Jul 29, 2019
1,286
0
0
Nothing you are doing wrong, add Fastcraft and see if that improves your performance...
 

zemerick

New Member
Jul 29, 2019
667
0
0
As tedy said, add fastcraft. 1.7.10 has some serious performance issues, and fastcraft is specifically designed to help.

Some more tips: Decrease your RAM as much as possible, and set both minimum and maximum to the same number. ( I had a lot of problems when I had them set different. ) I'm running 2.5 gigs, but I've both removed and added some mods, so you might need different numbers. ( Minecraft uses the RAM a lot, so the more you give it, the worse the performance. Obviously you need to give it enough to do the job though. )

Also, give Optifine a try. It's very hit and miss, but I got a MASSIVE performance boost this time around. ( Around my ReC Fusion Reactor I went from 8 FPS to 30FPS. )

It can also help to open your task manager and set javaw.exe to high priority ( Never realtime. Realtime bad! ) It might also help to close the FTB launcher, which is usually still running the tray. Just now it was using 1/4 gig at startup.

Don't expect it to run very well though. 1.7.10 is just all sorts of problematic.
 

Jakalth

New Member
Jul 29, 2019
83
0
0
The massive redwood trees found in plains biomes can be a cause of lag spikes, but tend to only do this if they are at the edge of your loaded chunks where they might load/unload as you move about. A few of the custom biomes(roofed forest biome being one for some reason), can, in some situations, cause reduced frame rates. They usually cause no problems though.

OpenGL helps a little with some types of lag, but not with others... Switching between having v-sync on/off can effect frame rates. But that all depends on how your graphics card like it to be set, it's different for everyone. One note here though, I tend to get more world holes and slow loading chunks with it turned OFF. Also setting a lower max frame rate(default is 120, I think?), can sometimes give you a higher frame rate ingame. And last of all, setting the view distance. Setting this even one setting below its max should reduce lag spikes and improve frame rates.

The major limitation with minrceaft is 1 thing, Java. Unlike a game like Battlefield 4, which uses a specialized engine to run the game, Minecraft uses Java, which is a generalist engine. Due to this, it takes more resources to do something, using Java, then it does when using a specialized engine. But there is less limitations to what you can do using Java.
 

Kezaraux

New Member
Jul 29, 2019
9
0
1
Thanks to everyone and their replies. I'll test these things out when I have a bit more time and report back here. Thanks again.
 

Kezaraux

New Member
Jul 29, 2019
9
0
1
Okay, here are my findings: After adding both Fastcraft and Optifine, without changing anything else, there was a slight increase in FPS. I then decided to change the amount of allocated RAM, both in the JVM and in the launcher to 2GBs. That was a terrible idea, kept maxing out the RAM and made it unplayable. Increase allocated RAM in the launcher to 3.5GB, and made the Xms and Xmx both 3G in the JVM. Much better. Tweaked optifine settings, changed frame rate limit to 75 frames, changed smooth lighting level to off, changed Advanced OpenGL to Fast, Chunk Loading to Multi-Core and that's about it. Now it seems to run at about 61-71 FPS, which I am content with. If I set the FPS limit to Unlimited, it will bump up to ~80 - ~89, but then will fall back down to ~58, so I decided to limit at 75. Thanks for the suggestions and advice! Time to go cause some chaos.
 

Jakalth

New Member
Jul 29, 2019
83
0
0
Glad those programs worked for you, much easier then trying to do something about redwood trees or having to try fixing the settings with java exceptions.