Launch loading extremely slow after update?

  • Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Djharts

New Member
Jul 29, 2019
411
0
0
Has this recent update cause anyone else's launcher to load extremely slowly. It's loading the previews for each mod pack very slowly. Is this due to the servers being overloaded or something?
 

Mr. Wimples

New Member
Jul 29, 2019
3
0
0
I too have been having a hard time updating and confirmed that it is not an issue of bandwidth and internet speed. Additionally, my java is up-to-date and I've re-downloaded the launcher to be certain.
 

zemerick

New Member
Jul 29, 2019
667
0
0
Mine loads fine. About 4 seconds from clicking the shortcut to everything being populated and pressing launch. I do have it on a SSD.

Perhaps check to see if you need to defrag.
 

Djharts

New Member
Jul 29, 2019
411
0
0
Nah. It's fixed now. This was right after an update. Probably just a bad night for the servers.
 

Mr. Wimples

New Member
Jul 29, 2019
3
0
0
For some reason I still have awful DL speeds when using the launcher. Is there a way to manually install the mods?

I attempted to do so by downloading the archive file specified in the console when the launcher attempts to update (in less than a second) and dropped it into the correct directory for the ultimate modpack, but the launcher still forces an update whenever I launch. As it stands now, the launcher downloads at less than 0.1 MB/s, which is beyond slow. As a comparison I downloaded Borderlands 2 in the time between my posts (at 10+ MB/s)