Infinity Server doesn't start properly

Onkelkopf

New Member
Jul 29, 2019
1
0
0
Hey everyone.
I am trying to start an Infinity Server, what doesn't work, but I'll explain this problem in detail later in this thread

  • What OS are you running?
Windows 7 Professional 64bit
  • Are you using minecraft hosting provider or a dedicated/local server not designed for minecraft?
No. I am just using the already made-up and given zip-server downloadable via the launcher.
  • What version of FTB are you using? (Dont just say latest tell us the version)
1.4.4
  • Did you add any mods to the server pack?
No
  • What are your server specs?
Since I am using my home-computer, that's quite easy to answer:
8gb Ram
Intel i5-2300 (2.8GHz quad core)
nVidia Geforce GTX 760
  • A good detailed paragraph about the problem

I downloaded the Infinity Mod Pack ( for Singleplayer and as Server )

It works completely fine when I start it as Singleplayer game (using the Launcher), but if I want to start the server I get an error:

Using the serverstart.bat AND the FTBServer.jar I keep getting the following message:

[14:38:29] [Server thread/INFO] [FML/]: The state engine was in incorrect state ERRORED and forced into state SERVER_STOPPED. Errors may have been discarded.


[14:38:29] [Server thread/INFO] [FML/]: The state engine was in incorrect state ERRORED and forced into state AVAILABLE. Errors may have been discarded.
I did agree to the eula, setting it to 'true' in my eula.txt In addition I also edited the serverstart.bat to assign more memory, so it looks like this:

java -server -Xms2048m -Xmx4096M -XX:permSize=2048m -d64 -XX:+UseParNewGC -XX:+CMSIncrementalPacing -XX:+CMSClassUnloadingEnabled -XX:parallelGCThreads=2 -XX:MinHeapFreeRatio=5 -XX:MaxHeapFreeRatio=10 -jar FTBServer-1.7.10-1291.jar nogui
I also updated both Java version (x64 and x86)

I hope the attached zip-file does work, so you might have a look into my log-file, since I don't find the source of my problem in this log =/
 

Attachments

Last edited:

Peoplesnem

New Member
Jul 29, 2019
1
0
0
Hey guys, i may or may not be right in saying. I think you forgot to change the setting in the eula file from 'false' to 'true'. Hope that helped. ;) made the same mistake.

The "eula" file is just a text doc in the server folder where ever you have it installed. Let me know if you need more help with that.
 

sonytantoni

New Member
Jul 29, 2019
3
0
0
Hey guys, i may or may not be right in saying. I think you forgot to change the setting in the eula file from 'false' to 'true'. Hope that helped. ;) made the same mistake.

The "eula" file is just a text doc in the server folder where ever you have it installed. Let me know if you need more help with that.
It says above he did agree to Eula, as did i
 

sonytantoni

New Member
Jul 29, 2019
3
0
0
I got it to work once by uninstalling and then reinstalling. After that I first opened the ftb server file and after that loaded a bit I opened the server start file and it worked. After I closed and started my computer again the next day tried to do the same thing but the ftb server file kept closing and couldn't get it running again.
 

Jerreco

New Member
Jul 29, 2019
6
0
0
Hey I had the same issue, but I solved it. Basically just update your java to the latest version and REMOVE OLDER VERSIONS. Make sure you do this BEFORE you download a server and try to run it, otherwise it wont work. Also make sure the EULA is set to TRUE, and not false before installing the server. Ill give a brief step by step process of what I did.

1. Go to java.com, and update your java to the latest version.
2. uninstall older versions.
3. restart your computer.
4. Make sure ftb launcher, and all the mods you want are installed on your computer.
5. Download the ftb server you want.
6. Extract compressed files into a new folder.
7. Open eula with notpad and make sure its set to TRUE BEFORE you start, or run the server.
8. Click the ftbinstall.
9. Finally click server start .bat.

You should be all set after that, gl :).

Side note: If you're having troubles with joining your own server locally, with your other computers on your OWN network, try adding more ram in the server.bat file. If someone needs me to explain how to do this I will go into more detail.
 
Last edited:

balthazar_yohlsko

New Member
Jul 29, 2019
3
0
0
Hey I had the same issue, but I solved it. Basically just update your java to the latest version and REMOVE OLDER VERSIONS. Make sure you do this BEFORE you download a server and try to run it, otherwise it wont work. Also make sure the EULA is set to TRUE, and not false before installing the server. Ill give a brief step by step process of what I did.

1. Go to java.com, and update your java to the latest version.
2. uninstall older versions.
3. restart your computer.
4. Make sure ftb launcher, and all the mods you want are installed on your computer.
5. Download the ftb server you want.
6. Extract compressed files into a new folder.
7. Open eula with notpad and make sure its set to TRUE BEFORE you start, or run the server.
8. Click the ftbinstall.
9. Finally click server start .bat.

You should be all set after that, gl :).

Side note: If you're having troubles with joining your own server locally, with your other computers on your OWN network, try adding more ram in the server.bat file. If someone needs me to explain how to do this I will go into more detail.
Thanks alot! This time it worked!
Also do you know how to put my old world in the new server? :)
 

Jerreco

New Member
Jul 29, 2019
6
0
0
Yep, I do! BEFORE you do anything make sure and open the server properties file with notepad. find the option that says "level-name=" and enter your old worlds name in their. Now save that. Delete the world file that you dont want and replace it with your old one. This is just a quick summary, I will also provide a step by step process below.

1. Open the folder that your server is in.
2. Scroll down until you see a .txt file name "server"
3. Click it and open with notepad.
5. Find "level-Name=" and delete the name "world" after the "=." then enter your old worlds name in there. Make sure to SAVE IT. For example: level-name=OldWorld.
(MAKE SURE the name of your old world is TYPED Correctly, caps included or it wont work!)
6. Go back into the folder that your server is in and delete the "World" folder.
7. Copy and paste your old world folder in their.
8. Start up the server, and your good to go.
 

Jerreco

New Member
Jul 29, 2019
6
0
0
You're welcome! Also, do you or any of you know where a list of all the server commands are. I'm curious to see if there is a command similar to /reload. I am aware that you can type /help, and look at the commands, but there isn't one called /reload. I'm sure there is a command that does the similar action as /reload, but I want to look at a complete list to see if i can find it. Thanks!
 

JefferyKaplan

New Member
Jul 29, 2019
1
0
0
Hey I had the same issue, but I solved it. Basically just update your java to the latest version and REMOVE OLDER VERSIONS. Make sure you do this BEFORE you download a server and try to run it, otherwise it wont work. Also make sure the EULA is set to TRUE, and not false before installing the server. Ill give a brief step by step process of what I did.

1. Go to java.com, and update your java to the latest version.
2. uninstall older versions.
3. restart your computer.
4. Make sure ftb launcher, and all the mods you want are installed on your computer.
5. Download the ftb server you want.
6. Extract compressed files into a new folder.
7. Open eula with notpad and make sure its set to TRUE BEFORE you start, or run the server.
8. Click the ftbinstall.
9. Finally click server start .bat.

You should be all set after that, gl :).

Side note: If you're having troubles with joining your own server locally, with your other computers on your OWN network, try adding more ram in the server.bat file. If someone needs me to explain how to do this I will go into more detail.
I had a problem but I'm not sure what caused it, I uninstalled Java and when I downloaded it again but server.bat kept showing this message:


C:\Users\Sufyan\Desktop\infinite server 2>if NOT "" == "yes" ()
Detected following JVM error:
=======================================
'cat' is not recognized as an internal or external command,
operable program or batch file.
=======================================
JVM test failed. Can't run server, Exiting...
Press any key to continue . . .
 

Jerreco

New Member
Jul 29, 2019
6
0
0
I had that problem to. All I did was restart my computer. First try deleting all off your old ftb server files. Restart your computer, and follow the steps I provided earlier. Also It is really important that you update java and REMOVE older versions BEFORE you try making a server. Im assuming you didn't do that, because that's what I tried and it ended up not working. Deleting old server files, and downloading them again is also just as important.