I have to add private packs to my launcher every time I log into the launcher

Status
Not open for further replies.

odinsembrace

New Member
Jul 29, 2019
68
0
0
Just like the title says, I add a private pack, such as 152wgt or FTBUnleashed and for some reason, the pack doesnt show up in the launcher unless I add the pack code again. I have to add the pack code each time I open the launcher or I cant play it. Also on top of this, the maps/filter settings button/and texture packs all do not show up untill I add a private pack.

Error log from my launcher.
 

NoPain9

New Member
Jul 29, 2019
171
0
0
I am having this 'bug' / 'error' aswell, atm I can't play Unleashed because I can't add it trough Private Packs cause it says "Invalid Private Pack" and it doesn't show the pack on the launcher currently.
 

odinsembrace

New Member
Jul 29, 2019
68
0
0
I am having this 'bug' / 'error' aswell, atm I can't play Unleashed because I can't add it trough Private Packs cause it says "Invalid Private Pack" and it doesn't show the pack on the launcher currently.

I know what you mean.... its a pain. I wish I could be playing it honestly, but it says invalid private pack. Same issue.

Anyone know a fix?
 

boclfon479

New Member
Jul 29, 2019
16
0
0
im having the same problem. in order to play on the new packs, every time i have to remove the private pack, add it back again, then go into filter settings and click apply in order to get them to show. ive tried deleving my FTB folder and redownloading the launcher, and I have tried running as admin to no avail.

EDIT:

I put the console on and this was the report:


Failed to load modpacks, loading from backup: java.io.IOException: Server returned HTTP response code: 403 for URL: http://england1.creeperrepo.net/static/FTB2/ Direwolf20_1_5.xml
Loading modpack information for Direwolf20_1_5.xml...
From Console: [Fatal Error] :2:1: Premature end of file.
Exception reading modpack file: org.xml.sax.SAXParseException; lineNumber: 2; columnNumber: 1; Premature end of file.

EDIT 2:

looking at the code, it seems the error is that in the direwolf URL, there is a space and thats causing an error
 

NoPain9

New Member
Jul 29, 2019
171
0
0
Nobody has yet to find a good solution for this?

The one you said Boclfon479 about the remove and readd is not possible for me. I can remove it, atleast it doesn't give me any messages or errors. But if I want to add Unhinged or Unleashed it says "Invalid Private Pack".

I really hope on of the FTB members read this posts as I really would like to play Unleashed and everything, but I just can't.
 

odinsembrace

New Member
Jul 29, 2019
68
0
0
still no help yet.. It reallysucks not to be able to play the new modpacks. I'm about to the point where I quit playing FTB all together and start making my own packs. This is starting to get ridiculous.
 

odinsembrace

New Member
Jul 29, 2019
68
0
0
I FOUND A FIX!!!!

go to start menu type %appdata% > click roaming > go down untill you find ftblauncer file > delete the file. after doing this I can run and play the game!
 

boclfon479

New Member
Jul 29, 2019
16
0
0
ive tried deleting the file and the entire folder but it doesnt work. that was one of the first things ive tried, but the info is being saved somewhere else besides the folder, just dont know where
 

Ashzification

New Member
Jul 29, 2019
7,425
1
0
To establish a baseline, please read the quote. Many problems are solved by the troubelshooting guide, and those that aren't, we can work on from here.
Please read below. Please be sure to read all of the info available in the 2 articles.
Please follow these steps exactly: http://desk.feed-the-beast.com/index.php?/Knowledgebase/Article/View/9/0/basic-troubleshooting
This is to rule out any issues with your setup. Please also read the extra info at the bottom of the guide, and apply all applicable suggestions.
Please attempt to launch the modpack, and open a new world save to make sure the setup is correct.
Now, continue on to check your previous saves, changes to the pack, textures, etc. until you're able to reproduce the error with the clean setup.

When the error has been repeated, please post your complete client-side (launcher) console log in debug-mode to pastebin.com and link your paste URL here.
To find your logs and prevent them from expiring: http://desk.feed-the-beast.com/inde...29/1/what-log-do-you-need-where-can-i-find-it
Can all of you try this?
Also after adding the private pack code, exit the launcher, then re-start it, and provide that launcher console via pastebin.com and link it.
 

NoPain9

New Member
Jul 29, 2019
171
0
0
Alright I may have a (hopefully) temporary solution. Atleast this worked for me.

When I open the launcher, I delete every new pack on it. So meaning: FTBUnhinged, FTBUnleashed AND Direwolf20_1_5. Afther 'removing' them. I ADD the Direwolf20_1_5 pack (this is the only one that works from the start), afther adding it, I use the "Filter Settings" button, leave it at default and just press "Apply Filter". Now the Direwolf pack is in there. NOW I add FTBUnleashed, press the Filter Settings again and it shows up for me. That's how I got it to work, which as I mentioned is hopefully a temporary solution.

So simple step:
1. Remove the 3 new packs even if you didn't add them.
2. Re-add the Direwolf pack using "Direwolf20_1_5".
3. Press Filter Settings, leave as default and "Apply Filter".
4. The Direwolf pack should now be in the launcher. Incase it didn't, try step 1 one again.
5. Should this be the case. Add the Unleashed pack using FTBUnleashed.
6. Press Filter Settings again, leave as default, and "Apply Filter".
7. Hopefully the pack should now be showing up.
 
  • Like
Reactions: Angelty and delcnz

gravitythief

New Member
Jul 29, 2019
3
0
0
The biggest issue i'm having right now is that none of the private pack codes are being considered valid. i can't add any private packs. I'm sure this isn't an issue on my part. perhaps the list of private modpacks is inaccessible by the launcher?
 

NoPain9

New Member
Jul 29, 2019
171
0
0
The biggest issue i'm having right now is that none of the private pack codes are being considered valid. i can't add any private packs. I'm sure this isn't an issue on my part. perhaps the list of private modpacks is inaccessible by the launcher?

Have you added them before perhaps or has it always been invalid. Otherwise try deleting them and then Direwolf pack first. That's how I got it to work somehow :)!
 

Ashzification

New Member
Jul 29, 2019
7,425
1
0
followed the steps and am still having the error, heres my paste bin

http://pastebin.com/BCKc7pNv
I'll first point out: you will not be able to play the game using the Java version you're currently using. Minecraft can't even run on java 8 yet, let alone FTB.
Code:
[00:09:54] [INFO] LaunchFrame.main:166: Java version: 1.8.0-ea
Also, see my report here: http://forum.feed-the-beast.com/threads/1-5-x-dw20-code.26872/

Change your filter settings to private and restart your launcher, and it should be there.
 

boclfon479

New Member
Jul 29, 2019
16
0
0
I'll first point out: you will not be able to play the game using the Java version you're currently using. Minecraft can't even run on java 8 yet, let alone FTB.
Code:
[00:09:54] [INFO] LaunchFrame.main:166: Java version: 1.8.0-ea
Also, see my report here: http://forum.feed-the-beast.com/threads/1-5-x-dw20-code.26872/

Change your filter settings to private and restart your launcher, and it should be there.
i have been using Java 8 with no problems for at least 2 months while using FTB, and after i put in the pastebin, i removed java 8 and put on java 7 and it still gives me the same errors

EDIT:

also it seems when i close the launcher it resets the settings, not sure why it does though.
 

Ashzification

New Member
Jul 29, 2019
7,425
1
0
i have been using Java 8 with no problems for at least 2 months while using FTB, and after i put in the pastebin, i removed java 8 and put on java 7 and it still gives me the same errors

EDIT:

also it seems when i close the launcher it resets the settings, not sure why it does though.
I'd love to know how you got it working, as Minecraft shouldn't be running on 8 yet.
New log please.
 

boclfon479

New Member
Jul 29, 2019
16
0
0
I figured out the problem!

I have my FTB putting my minecraft versions into .FTB, but i never realized it also created an "ftblauncher" folder that contains all the configs and stuff. I deleted the folder( from roaming) and ran the launcher and now i have no problems whatsoever
 
  • Like
Reactions: Vauthil
Status
Not open for further replies.