Problem FTB Unleashed Server Stuck

lifeseeker128

New Member
Jul 29, 2019
25
0
0
I've been trying to create an FTB Unleashed sever on my Linux machine with all the optional mods enabled, but the server building process seems to freeze after a certain point. I'd planned to add a couple more mods, but the server won't complete building itself. I've been able to run the same files on my personal Windows 7 machine with no freezing.

My error log file is attached. Someone please help me figure out what's wrong and how to fix it.

EDIT: I've attempted to import the server from my Windows 7 machine into the Linux one and run it, but it freezes at the same spot just after loading TConstruct after hitting IC2 API's failed attempt at calling getItem for refinedUranium; don't think these two things are connected. Could it be a problem with running the .sh file instead of the .bat? I don't know how I could run the .bat with Linux so .sh is all I know how to do on my server machine.

EDIT2: I have made changes to my .bat and .sh files so they are allowed to take more ram and produce no gui on start up. I made that change before I ran the server the first time. I've noticed, however, that there's another field within the files when opened in notepad. What is "-XX:'PermSize=128m" (without the extra " ' ")mean and could it be causing a problem? It doesn't seem to affect anything when running from the .bat.

EDIT3: I just tried running the server on Linux without enabling any disabled mods. Still, it freezes after loading TConstruct.
 

Attachments

  • ForgeModLoader-server-0.txt
    384.6 KB · Views: 17

Cozza

New Member
Jul 29, 2019
320
0
0
When this happens to me it's normally because i stuffed up file ownership permissions.

Check which user java is running under and make sure the rest of your files are also owned by that user
 

lifeseeker128

New Member
Jul 29, 2019
25
0
0
I tried using the chmod command in Linux to unlock all permissions for the files in my server folder, but now I try to run ServerStart.sh and I get the error in the attached log.

More help would be appreciated. It's not the same freezing as before. This error just shuts the server down in a "fatal error".

EDIT: I have enabled all the mods, added Useful Foods, added ForgeEssentials, and unlocked all the file permissions before running ServerStart.sh.
 

Attachments

  • ForgeModLoader-server-2.txt
    19.5 KB · Views: 15

Cozza

New Member
Jul 29, 2019
320
0
0
Code:
2013-09-04 08:16:39 [SEVERE] [ForgeModLoader] There were errors during initial FML setup. Some files failed to download or were otherwise corrupted. You will need to manually obtain the following files from these download links and ensure your lib directory is clean.
2013-09-04 08:16:39 [SEVERE] [ForgeModLoader] *** Download http://files.minecraftforge.net/fmllibs/argo-small-3.2.jar
2013-09-04 08:16:39 [SEVERE] [ForgeModLoader] *** Download http://files.minecraftforge.net/fmllibs/guava-14.0-rc3.jar
2013-09-04 08:16:39 [SEVERE] [ForgeModLoader] *** Download http://files.minecraftforge.net/fmllibs/asm-all-4.1.jar
2013-09-04 08:16:40 [SEVERE] [ForgeModLoader] *** Download http://files.minecraftforge.net/fmllibs/bcprov-jdk15on-148.jar
2013-09-04 08:16:40 [SEVERE] [ForgeModLoader] *** Download http://files.minecraftforge.net/fmllibs/deobfuscation_data_1.5.2.zip
2013-09-04 08:16:40 [SEVERE] [ForgeModLoader] *** Download http://files.minecraftforge.net/fmllibs/scala-library.jar
2013-09-04 08:16:40 [SEVERE] [ForgeModLoader] *** Download https://github.com/ForgeEssentials/ForgeEssentialsMain/raw/master/lib/mysql-connector-java-bin.jar
2013-09-04 08:16:40 [SEVERE] [ForgeModLoader] *** Download https://github.com/ForgeEssentials/ForgeEssentialsMain/raw/master/lib/H2DB.jar
2013-09-04 08:16:40 [SEVERE] [ForgeModLoader] *** Download https://github.com/ForgeEssentials/ForgeEssentialsMain/raw/master/lib/metrics-R7-FEmod.jar
2013-09-04 08:16:40 [SEVERE] [ForgeModLoader] *** Download https://github.com/ForgeEssentials/ForgeEssentialsMain/raw/master/lib/pircbotx-1.9.jar
2013-09-04 08:16:40 [SEVERE] [ForgeModLoader] <===========>
2013-09-04 08:16:40 [SEVERE] [ForgeModLoader] The following is the errors that caused the setup to fail. They may help you diagnose and resolve the issue
2013-09-04 08:16:40 [SEVERE] [ForgeModLoader] A download error occured
2013-09-04 08:16:40 [SEVERE] [ForgeModLoader] A download error occured
2013-09-04 08:16:40 [SEVERE] [ForgeModLoader] A download error occured
2013-09-04 08:16:40 [SEVERE] [ForgeModLoader] A download error occured

ForgeEssentials is not downloading its dependancies. So the server can't boot.

I highly suggest MCPC+ :)
 

lifeseeker128

New Member
Jul 29, 2019
25
0
0
Alright, I just removed ForgeEssentials and it got over this other error, but the previous error is still there and it won't continue past the same point. Could it just be taking a while to load past the next point? I think I'll wait for several minutes to see if it finally loads.
 

Cozza

New Member
Jul 29, 2019
320
0
0
You said you used chmod and changed the permissions. I'm concerned about the owner (Because the server runs fine in windows).

Easiest way is to chown the whole server directory recursively to the correct owner.

chown -R username:username /serverfolder
 

lifeseeker128

New Member
Jul 29, 2019
25
0
0
I used "sudo chmod 777 -R <path>" and it seemed to work out fine, but that wasn't the problem. I got the thing to work after disabling my VPN. The server was having trouble downloading through it. I can log into the server and it runs now. Thanks for all the help though.
 

Mr Chris

New Member
Jul 29, 2019
51
0
0
You really dont want to use 777 as a 'fix', even if its just a server for friends or whatnot, its a bad habit to get into.