flood console

Discussion in 'Server Tech Support' started by smenes, Dec 10, 2013.

  1. smenes

    smenes New Member

    Hi
    I have always this in my console

    Code:
    2013-12-10 11:36:05 [INFO] [STDERR] java.util.ConcurrentModificationException
    2013-12-10 11:36:05 [INFO] [STDERR]    at java.util.HashMap$HashIterator.nextEntry(HashMap.java:926)
    2013-12-10 11:36:05 [INFO] [STDERR]    at java.util.HashMap$ValueIterator.next(HashMap.java:954)
    2013-12-10 11:36:05 [INFO] [STDERR]    at net.minecraft.nbt.NBTTagCompound.func_74734_a(SourceFile:25)
    2013-12-10 11:36:05 [INFO] [STDERR]    at net.minecraft.nbt.NBTBase.func_74731_a(SourceFile:119)
    2013-12-10 11:36:05 [INFO] [STDERR]    at net.minecraft.nbt.CompressedStreamTools.func_74800_a(CompressedStreamTools.java:140)
    2013-12-10 11:36:05 [INFO] [STDERR]    at net.minecraft.world.chunk.storage.AnvilChunkLoader.func_75821_a(AnvilChunkLoader.java:198)
    2013-12-10 11:36:05 [INFO] [STDERR]    at net.minecraft.world.chunk.storage.AnvilChunkLoader.func_75814_c(AnvilChunkLoader.java:184)
    2013-12-10 11:36:05 [INFO] [STDERR]    at net.minecraft.world.storage.ThreadedFileIOBase.func_75736_b(SourceFile:30)
    2013-12-10 11:36:05 [INFO] [STDERR]    at net.minecraft.world.storage.ThreadedFileIOBase.run(SourceFile:23)
    2013-12-10 11:36:05 [INFO] [STDERR]    at java.lang.Thread.run(Thread.java:744)
    how to fix that ?

    thank
     
  2. Slind

    Slind Well-Known Member

    new horizons pack ? I think this has to be fixed by ftb
     
  3. NEXUS2345

    NEXUS2345 New Member

    This is a common thing, this looks to be something to do with a mod called 'CompressedStreamTools' or at least a class. This also has something to do with an NBT tag, so basically there is something that is assigning an invalid NBT tag possibly.
     
  4. Puggy

    Puggy New Member

    I am getting the exact same error in my custom mod pack. Really annoying.

    Code:
    2013-12-13 23:04:53 [INFO] [STDERR] java.util.ConcurrentModificationException
    2013-12-13 23:04:53 [INFO] [STDERR]    at java.util.HashMap$HashIterator.nextEntry(HashMap.java:926)
    2013-12-13 23:04:53 [INFO] [STDERR]    at java.util.HashMap$ValueIterator.next(HashMap.java:954)
    2013-12-13 23:04:53 [INFO] [STDERR]    at net.minecraft.nbt.NBTTagCompound.func_74734_a(SourceFile:25)
    2013-12-13 23:04:53 [INFO] [STDERR]    at net.minecraft.nbt.NBTBase.func_74731_a(SourceFile:119)
    2013-12-13 23:04:53 [INFO] [STDERR]    at net.minecraft.nbt.CompressedStreamTools.func_74800_a(CompressedStreamTools.java:140)
    2013-12-13 23:04:53 [INFO] [STDERR]    at net.minecraft.world.chunk.storage.AnvilChunkLoader.func_75821_a(AnvilChunkLoader.java:198)
    2013-12-13 23:04:53 [INFO] [STDERR]    at net.minecraft.world.chunk.storage.AnvilChunkLoader.func_75814_c(AnvilChunkLoader.java:184)
    2013-12-13 23:04:53 [INFO] [STDERR]    at net.minecraft.world.storage.ThreadedFileIOBase.func_75736_b(SourceFile:30)
    2013-12-13 23:04:53 [INFO] [STDERR]    at net.minecraft.world.storage.ThreadedFileIOBase.run(SourceFile:23)
    2013-12-13 23:04:53 [INFO] [STDERR]    at java.lang.Thread.run(Thread.java:724)
    
     
  5. Connor Gavitt

    Connor Gavitt New Member

    Could just be that mod version isn't working right, I have yet to get into 1.6.4 packs so I'm not the most reliable on this topic.
     
  6. Francis Baster

    Francis Baster New Member

    I've had this error since FTB Ultimate, presumably it is two threads trying to edit the same NBT tag simultaneously. Maybe a poorly coded mod that doesn't use locks? Not sure.
     
  7. Puggy

    Puggy New Member

    It is a rather odd error, I find that while my server shuts down during a restart two mods seem to have issues "saving". Applied Energistics' Controller throws a save error as well as Mekanism's Universal Cables. Both which I believe are classified as entities.
     
  8. Divinder

    Divinder New Member

    I started seeing this spam on my server after I put an Ender-thermic pump in the nether with a Ender Tank, after I removed them no more spam...I already made a post on extra utils thread but could be something else not sure at this point.
     
  9. Addar

    Addar New Member

    I'm getting this same error spammed in my console as well.. :(
     
  10. Spasticon

    Spasticon New Member

    You guys using ender-thermic pumps in your worlds? What happens if you pick those up?
     
  11. BenJM001

    BenJM001 New Member

    Ok so I'm having this problem too and it has caused me to have to restart my world at least twice already in the last week. I have been using the ender-thermic pumps but removing them has not stopped the constant spam in the server console. Does anybody actually know how to fix this or have we got to wait for an update of the pack. (I am using Monster 1.0.3 btw)
     
  12. jefrbunn

    jefrbunn New Member

    I am having this issue and I am not using an enderthermic pump anywhere. I am using a regular BC pump and have setup an AE network.
     
  13. EliteNeet

    EliteNeet New Member

    It is a general chunk loading issue, I have found its not just the enderthermic pump. Any block that chunk loads causes the problem.
     
  14. blood

    blood New Member

    Last edited: Jan 26, 2014
    Francis Baster likes this.
  15. jefrbunn

    jefrbunn New Member

    That is cool that you have found it. Is it fixed in a newer version? Maybe we should post that in his forum?
     
  16. blood

    blood New Member

    Be my guest. If he doesn't fix it, i'll post a fixed version for you guys later tonight.
     
  17. jefrbunn

    jefrbunn New Member

    an update would be nice because this is what seems to be slowing my server... it slows my CPU drops to like 1% and then everyone gets socket errors. Crazy this is so unstable.
     
  18. blood

    blood New Member

    The author posted this recently on his forum "Retrogen is broken and not supposed to be in use." However, he is still registering the RetroGenController with Forge's EventBus which continues to monitor ChunkDataEvent.Load events.


    Link removed as requested by author. Contact him to fix the bug.
     
    Last edited: Jan 27, 2014
  19. LeChuuck

    LeChuuck New Member

    Im getting spammed by this in console and the only answer we get from Reika is, "The class itself is in DragonAPI, but the execution is called from the mods' end. DragonAPI does very little on its own.
    In all likelihood, it is not the retrogen doing this."

    If you could post a fix, would be very appreciated.
     
  20. EliteNeet

    EliteNeet New Member

    update to the newest version, 15b. He disabled his retrogencontroller and I am no longer getting the console spam on my server.

    blood I would like to thank you for finding the offending mod, I spent so long searching an answer. Much appreciated!
     

Share This Page