1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Ender IO and Thermal expansion not working together

Discussion in 'General FTB chat' started by Dierke9, Feb 2, 2015.

  1. Dierke9

    Dierke9 New Member

    Hi

    i have both Ender IO and Thermal expansion but they don't work together i've seen on video's that they should work together but they don't for me. When i try to hook up an energy conduit from Ender IO on a Thermal Expansion machine they just don't connect with eachother i've tried to transer energy from 1 energy cell to another and this doesn't work either with a ender io conduit. The problem is that the redstone energy conduit are gone from my game. Is this a config bug or ?
     
  2. rdemay91

    rdemay91 Active Member

    Wat version are you using? If enderio isn't up to date then you might have a version that has a different api and it won't work.
     
  3. rhn

    rhn Too Much Free Time

    1. TE energy conduits/fluidducts/itemducts have been exported to a standalone mod. It is still WIP.
    2. Have you tried wrenching the EIO conduits?
     
  4. Dierke9

    Dierke9 New Member

    I have version 2.8.260

    What do you mean with that ? do you mean like the end of the pipes or ?
     
  5. NinjaPig31

    NinjaPig31 Member

    Shift right click with your yeta wrench and choose the direction fiddling around a bit you should be able to fix it.

    Another thing is that you can move fluids or items from the top of dynamo because that is only for power. I made that mistake becuase you can place multiple ender io conduits in one block.
     
  6. Dierke9

    Dierke9 New Member

    If i shift rightclick something with my Yeta wrench it just destroys it and the item duct from Ender IO works on my TE machines but the power ducts dont
     
  7. DriftinFool

    DriftinFool Well-Known Member

    I think it is actually shift+left click. It will open a GUI where you can choose a direction (N,S,E,W, up, or down) and force a connection.
    Even with versions that work together, I have had issues with energy cells or tesseracts connected directly to a capacitor bank. The capacitor banks can be set to input, output, both in and out, and blocked by clicking them with a wrench. I found when I a put a cell or tesseract directly on them, it changed the mode they were in and it wasn't always the setting I wanted. Putting a conduit between them is a simple fix for it.

    As for the issue you are having, I have seen a post or 2 with others having the same issue. Seems an API change along the way somewhere is making a few mods that use RF not play well together. I am using the current Direwolf pack and Ender IO and TE work together just fine. Maybe take a peek at the changelog for the pack to see which versions they are using so you find the ones that work together.
     
  8. NinjaPig31

    NinjaPig31 Member

    I am so sorry I meant shift left click just wasnt thinking straight
     
  9. Dierke9

    Dierke9 New Member

    Well i just tried the shift left click with a yeta wrench on a energy conduit. and it doesnt work either so idk what the problem is but i will take alook in direwolf pack what version they use.
     
  10. King Lemming

    King Lemming Thermal Expansion Dev FTB Mod Dev

    You need to update something. My guess is that your EnderIO is out of date.
     
    ThatOneSlowking likes this.
  11. NinjaPig31

    NinjaPig31 Member

    What version is your direwolf20 pack?

    You could maybe make a backup of your world and redownload the direwolf20 pack.

    And did you add in any other mods?
     
  12. Dierke9

    Dierke9 New Member

    Well i'm not using the direwolf20 pack but using my own modpack and i was wondering why it didn't work.
     
  13. MigukNamja

    MigukNamja Forum Addict

    You seem to have encountered the issue that all pack-makers from amateur to season veteran have encountered since the 1st modpack : mismatched mods.

    It's for this reason that my packs are usually relatively slow to update. Once I have something working, I stick with it.

    In your case, I recommend pulling down the latest each of eIO and TE and verifying via their changelogs they work well together.
     
  14. Karimiri

    Karimiri Active Member

    yeah abou that, can you poke someone to release temporary fix or something ?

    last enderIO download i can find 2.2.8.349 is over month old, thermal (today) is latest and this problem stil exists.
    good there are no crashes, but downgrading is not an option.

    hehe, spoke too soon - connecting tesseract and buildcraft stuff crashes everything :p

    Description: Exception in server tick loop

    java.lang.IncompatibleClassChangeError
    at crazypants.enderio.power.EnergyReceiverPI.recieveEnergy(EnergyReceiverPI.java:66)
    at crazypants.enderio.conduit.power.NetworkPowerManager.doApplyRecievedPower(NetworkPowerManager.java:152)
    at crazypants.enderio.conduit.power.NetworkPowerManager$InnerTickHandler.tickEnd(NetworkPowerManager.java:539)
    at crazypants.enderio.conduit.ConduitNetworkTickHandler.tickEnd(ConduitNetworkTickHandler.java:47)
    at crazypants.enderio.conduit.ConduitNetworkTickHandler.onServerTick(ConduitNetworkTickHandler.java:35)
    at cpw.mods.fml.common.eventhandler.ASMEventHandler_198_ConduitNetworkTickHandler_onServerTick_ServerTickEvent.invoke(.dynamic)
    at cpw.mods.fml.common.eventhandler.ASMEventHandler.invoke(ASMEventHandler.java:54)
    at cpw.mods.fml.common.eventhandler.EventBus.post(EventBus.java:138)
    at cpw.mods.fml.common.FMLCommonHandler.onPostServerTick(FMLCommonHandler.java:247)
    at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:590)
    at net.minecraft.server.integrated.IntegratedServer.func_71217_p(IntegratedServer.java:111)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:427)
    at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685)
     
    Last edited: Mar 29, 2015
  15. b0bst3r

    b0bst3r Popular Member

    What versions are your TE suite of mods?

    EIO hasn't updated in a month because they are all working on a new version which has many changes.
     
  16. Karimiri

    Karimiri Active Member

    CoFHCore-[1.7.10]3.0.0RC7-211
    CoFHLib-[1.7.10]1.0.0RC7-127
    MineFactoryReloaded-[1.7.10]2.8.0RC8-86
    RedstoneArsenal-[1.7.10]1.1.0RC7-65
    ThermalExpansion-[1.7.10]4.0.0RC7-141
    ThermalFoundation-[1.7.10]1.0.0RC7-62

    and of among those changes will be implemented updated RF-API i hope xD
    on the other hand while testing i removed EIO from mods folder and i gues ill just swap it with ThermalDynamics-[1.7.10]1.0.0RC7-98 instead.
    will be a paint to rebuil all this piping to get everything to work again but i prefer 10 working-bug-free updated mods over 11 "soon(TM)" ones
     
  17. King Lemming

    King Lemming Thermal Expansion Dev FTB Mod Dev

    I don't get that error. I truly have no idea what to tell you. The Thermal series works fine, and seems to work alongside EnderIO in every instance I've tested.
     
  18. b0bst3r

    b0bst3r Popular Member

    I wish you'd really post a full crashlog so we can see versions of everything and not just the error.
     
  19. Azzanine

    Azzanine Forum Addict

    I will also verify that EIO conduits most certainly work with later version of Thermal Exp.
    Versions used;
    EnderIO-1.7.10-2.2.8.349
    ThermalExpansion-[1.7.10]4.0.0RC7-141
    CoFHCore-[1.7.10]3.0.0RC7-211
     
  20. Psychicash

    Psychicash Well-Known Member

    There's something that I haven't seen anyone mention. (I think, sorry if I'm repeating)

    With TE machines you still have to select input or output on the machines. Even if you have an ender io pipe set to extract, TE won't allow anything to take it from a side that isn't defined.

    So both ender io and TE machine have to be set to input or extract for it to work.
     

Share This Page