DW20 lag problem. Which mod is causing it?

  • Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

NunoAgapito

New Member
Jul 29, 2019
1,159
0
0
No, this is not another post asking for help about lag when the player failed to install fastcraft...

I have fastcraft, I disabled texture packs, I start the pack with MultiMC, I dont have too much memory assigned to the pack, I disabled JorneyMap, I pregen world, etc...

I did all the tips and tricks known but still, there is something wrong with 1.7.10. And I mean 1.7.10 packs, not only the DW20 pack. I start with some "acceptable" FPS, in my case around 40 fps (which is strange since in vanilla I can have 200!!!) and after 1-2 hours of gameplay my FPS just crashes to almost 0 forcing me to restart the client. If I do multiple trips to the nether, when I go for the third/forth time, FPS goes down to 2-3 and I have to restart the client again...

This happens with almost every 1.7.10 pack... And yesterday night, I was sure it was not a problem on my machine. Some mod is causing this! I was watching Wyld's stream and he was playing the official pack for the first time and he was complaining about the same... But, the funny thing, he didnt had this problem when he tested the beta pack. He would play the game for hours(7-8) with no lag problems, high FPS(>100), smooth... Now, he was getting 60 after restart and after 1-2 hours... he needed to restart the client again!

Some mod is causing issues and must be a common mod, since this seems to happen with most 1.7.10 modpacks I played...

Minecraft debug mode(shift+F3) told me that the problem usually is related with calculating lighting levels or calculating entities movement but most of the times, when the fps drops, my processing power is being consumed by light levels calculation....

The question is, which mod is causing all the problems and poor performance?
 

NunoAgapito

New Member
Jul 29, 2019
1,159
0
0
Only once I seen my client massively leaking... The javaw process was consuming 6-7GB of RAM but usually it is on the 2-3GB and the problems are still there!
Also, the java client himself as memory leaks problem, so... I dont know if the leak was from MC or java. In 1.6.4, java would leak and use 7-8GB of RAM and I would not have this problems...
 

McJty

Over-Achiever
Mod Developer
May 13, 2014
2,016
2,520
228
twitter.com
You could perhaps try Opis? There is a version for 1.7.10 now and it might help pinpoint the exact problem.

BTW, in my own custom 1.7.10 modpack I have not yet experienced this problem.
 

Racemol

New Member
Jul 29, 2019
232
0
0
For fun sake, try a different (MultiMC) launcher. I wouldn't have believed something like that would work but I had the same issues, tried to disable a few mods but it wouldnt do much. Then I found this post and just tried it. I went from extreme stutters to a 120FPS+ smooth gameplay, just by using a different launcher.
 

NunoAgapito

New Member
Jul 29, 2019
1,159
0
0
I think you guys are missing the point.

Beta pack of DW20 worked flawless! Wyld was one of the testers and he streamed it for days while testing it. He come back from PAX Aus, downloaded the official version and with the same settings he used before, he has problems too!

So, its not something like, MC 1.7.10 and we have to learn to live with it! Something changed and that is causing the problem!
 

epidemia78

New Member
Jul 29, 2019
1,815
0
0
Well, whats different? What version of forge is the most stable? For a while there everyone was saying to stick with 1208 even though it was outdated.
 

epidemia78

New Member
Jul 29, 2019
1,815
0
0
Any specifications on what version mods were being used in the beta? My gut tells me forge needs to be downgraded...
 

MigukNamja

New Member
Jul 29, 2019
2,202
0
0
Probably a memory leak. I get the same experience in 1.7.10 packs when I use the FTB launcher without any arguments. Assuming you have at least a 4-core processor, try these Java arguments:

Code:
-Xmx4096M -Xms2048M -XX:PermSize=256m -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalPacing -XX:ParallelGCThreads=4 -XX:+AggressiveOpts -XX:NewRatio=3 -XX:SurvivorRatio=3 -XX:TargetSurvivorRatio=80 -XX:MaxTenuringThreshold=8 -XX:+UseParNewGC -XX:MaxGCPauseMillis=10 -XX:GCPauseIntervalMillis=50 -XX:MaxGCMinorPauseMillis=7 -XX:+ExplicitGCInvokesConcurrent -XX:+UseCMSInitiatingOccupancyOnly -XX:CMSInitiatingOccupancyFraction=60 -XX:+BindGCTaskThreadsToCPUs -Xnoclassgc
My 1.7.10 client works far better with the above args.
 

egor66

New Member
Jul 29, 2019
1,238
0
0
I hate to say this but wait for a stable version, none of the tips n tricks I normally use to help with fr/block lag seem to work in the new DW pack, & dont forget DW streams/tubes on a server alone, the server is taking a lot if not most of the load, to play this pack even on a good to high end pc seems pointless atm, there are so many issues you will run into as you progress, I had a world with little if any lag until I uses mystcraft now both ages lag like hell, most other maps did not even get that far, sad part is DW is streaming with what seems to be an unfinished beta.

& yes I am ready for the back lash, I have been a DW fan for years but this is....oh never mind
 
Last edited:

epidemia78

New Member
Jul 29, 2019
1,815
0
0
I hate to say this but wait for a stable version, none of the tips n tricks I normally use to help with fr/block lag seem to work in the new DW pack, & dont forget DW streams/tubes on a server alone, the server is taking a lot if not most of the load, to play this pack even on a good to high end pc seems pointless atm, there are so many issues you will run into as you progress, I had a world with little if any lag until I uses mystcraft now both ages lag like hell, most other maps did not even get that far, sad part is DW is streaming with what seems to be an unfinished beta.

& yes I am ready for the back lash, I have been a DW fan for years but this is....oh never mind
Im afraid you might be right. Its a hard thing for me to accept, downgrading after testing out some of the new mod features, and all the time Ive spent tweaking my personal pack... (which is pretty close to the DW20 pack). I am not quite ready to give up on it just yet though. It does seem like theres a memory leak issue with Mystcraft (a recurring problem with that mod), and I also noticed during testing that BoP biomes seem to lag a lot worse in comparison to Highlands biomes.
 

tedyhere

New Member
Jul 29, 2019
1,286
0
0
The dimension memory link is vanilla, don't believe me go to the nether and back to the overworld as many times as fast as possible. It's been a bug for a while
 

techbrew

New Member
Jul 29, 2019
5
0
0
FWIW, I've observed the same problems with Dark Trilogy for 1.7.10. Going to nether or mining world and back makes NEI and container interactions slow to a crawl, as well as a significant FPS drop. Going from 2GB to 6GB was the only way I got any lasting relief from the annoyance.
 

NunoAgapito

New Member
Jul 29, 2019
1,159
0
0
Well, I found out updating to Java 8 solved all my problems....

Went from resetting the client every 30 mins to having it running for 7 hours straight. (Would be more but Java(not MC) crashed with a memory access violation :p)
 

asb3pe

New Member
Jul 29, 2019
2,705
4
1
I don't think Forge works with the latest version j8_25 yet so you have to run a prior version like j8_11. At least that's what I read and yeah I run pretty smooth on it. In fact, the game runs so smoothly I figured I could safely go ahead and add in my fave resource pack, 64x Sphax for Direwolf modpack, all I had to do was click "use advanced java settings for fast computers" and set the slider to 6GB of ram. Not using any java arguments at all. 128x Sphax just wouldn't run tho, arguments or not, way too laggy even giving it as much as 10 gigs lol.