Disable hardcore mode and any of the HQM lives on Crash Landing server

  • Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Dodge34

New Member
Jul 29, 2019
511
0
0
OK, don't judge me for wanting this please, and if its against the rules to ask here about this, please can you forgive me for this one, I already know how to use NBTExplorer and already have it installed, the problem is since I and my brother will play on a server (100% private family server here), I'm not sure where to find the correct level.dat file to edit and if there's anything I need to disable to have also unlimited number of lives, I have HQM on the Utopia3 pack but it didn't had any hardcore mode enabled on it so we had unlimited lives already there so I had no problems. The adventure looks like real epic and I want to try it really bad, but we already died 5 times each and restarted from scratch every single time, we've learned some of the basics of this awesome adventure, but I don't want to try again if there's no ways to disable the hardcore mode and HQM lives system.
 

Azzanine

New Member
Jul 29, 2019
2,711
-7
0
I think if you disable regular vanilla hardcore mode you disable HQM's lives.
HQM changes how vanilla hardcore mode in a fundamental way.
You might need to check your server config to see what difficulty it's set to because HQM unless specified otherwise in the config turns Hardcore mode on.
*servermodpackfolder*\minecraft\config\hqm\hqmconfig.cfg should be the correct path
Code:
general {
    # If set to true, new worlds will automatically activate Hardcore mode
    B:"Auto-start hardcore mode"=false
< that's copied from MaterialEnergy4's config and at least for me it has no lives.
That should stop new worlds from setting Hardcoremode by default, as for setting current worlds to normal not sure how it's done.
 

Dodge34

New Member
Jul 29, 2019
511
0
0
Thanks, checked out the config, strangely, Hardcore mode doesn't seem to be enabled either on a brand new server I'm preparing to start, or in the current one that we plan to restart anyways, according to both level.dat hardcore mode is set to 0, I've also checked the config for the HQM thingy and also its already set to false for hardcore mode,

NVM, it turns out the server.properties also has an hardcore setting I needed to turn off, and also difficulty to 2 instead of 3 so we won't instantly die when we first encounter a mob.
 

Azzanine

New Member
Jul 29, 2019
2,711
-7
0
Might wanna turn off mob griefing too, otherwise death creepers will quickly whittle your little ship down.
 

Dodge34

New Member
Jul 29, 2019
511
0
0
Might wanna turn off mob griefing too, otherwise death creepers will quickly whittle your little ship down.
Its already done by default for the 1.1.3 version we have, mob grirfing is turned off, now if I could find the easiest way to disable some of the special mobs (all of their flying versions and perhaps some kind of stupid spider that get all my stuff, I had to kill it bare hands to get my precious stuff back, not sure of its exact name but I want to get rid of that stupid modder idea of a funny mob, I swear if I ever meet him in real life, he will know what I think about his thief spider of some kind.