Bug Direwolf20 1.0.1 takes forever to load

  • Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here
  • FTB will be shutting down this forum by the end of July. To participate in our community discussions, please join our Discord! https://ftb.team/discord

Aaron5015

New Member
Jul 29, 2019
174
0
0
Okay to be honest i have no idea where to put this either if it was a bug or something that can be fixed from just general So for now im putting here.

It takes 10 years to load...plain as that idk why ...dont ask but can anyone help?
 

Dezz

Well-Known Member
Jul 13, 2013
281
107
78
When you are loading this many mods, it's going to take a while. This isn't an issue, really. It can be expected of a pack that's (decently) large.
 

asb3pe

New Member
Jul 29, 2019
2,704
1
1
I dunno, compared to the GregTech modpack (3rd Party, InfiTech2, takes at least 2-3 minutes to load in), the Direwolf modpack loads at light speed. Everything is relative. :)

But honestly... on my computer DW loads very quickly, well within one minute (perhaps even within 30 seconds). It's quite quick compared to most modpacks I play. I'd suspect it's something on your end but without knowing your computer, your OS, your memory, your java, your java arguments, etc... who knows. If you know what you're doing (be careful if you have games in progress, backup your save folders), I'd start with a fresh install of the FTB launcher and then do a fresh install of DW modpack.
 

dem0z

New Member
Jul 29, 2019
22
0
0
well for me it takes exactly 90 seconds to open and i have a "beefy" pc how long does it take for you to open is it like over 5 minutes?
 

Aaron5015

New Member
Jul 29, 2019
174
0
0
well the old dw20 pack took not like 20 minutes load. *it didnt even load after 20 minutes*
 

dem0z

New Member
Jul 29, 2019
22
0
0
even with old dual core it didn't take that long what is your pc specs if you don't mind me asking?

also make sure to set the maximum ram in the launcher to 4gb at least maybe that will help
 

Chaka

FTB Team
Mod Developer
Retired Staff
Dec 24, 2013
928
323
103
New Jersey
It takes me about 3 min and 30 sec and I have a bad computer

Sent from my flux armor using the tappatalk app from the flux store
 

FyberOptic

New Member
Jul 29, 2019
524
0
0
I couldn't help but notice that a decent portion of the loading happens before the Mojang logo even appears, which implies to me that several mods are injecting code, on top of Forge doing so itself nowadays. Not sure why so many mods still do so, but that's part of it.

If you're using a high-res texture pack, that won't help either.
 

Aaron5015

New Member
Jul 29, 2019
174
0
0
jxguVNY.png
 

asb3pe

New Member
Jul 29, 2019
2,704
1
1
It must be either system-related or a bad installation of the modpack or FTB, because on my system this is literally one of the fastest loading modpacks of all the packs I've played. It's less than 30 seconds from the time I click Launch until the time I can click Single Player and enter my world.

EDIT: Aaron, ignore what I wrote below, I didn't see you only have 4GB RAM installed, so you shouldn't use those java arguments. Just set your RAM Maximum slider to 2.5GB and see if that helps you.

I should add I do have a lot of RAM and am using j8_11 (which is an older version and not recommended since it doesn't have all the latest security updates) with these java arguments. Note that they're only recommended for systems with 8GB of RAM or more. That's prob why mine loads so fast tho, honestly. But worth a shot perhaps. Even if you're still using j7 (which is recommended for FTB), you might want to try the j7 argument string and see if it helps any. I don't use the last "IPv4" argument because that really only applies to people running SMP servers I think, not SSP.
 
Last edited:

Hambeau

Over-Achiever
Jul 24, 2013
2,598
1,531
213

First, you can't bump your ram allocation to 4GB as advised... You have to keep at least 1.5GB reserved for your OS, if it is Windows. If it's a laptop then chances are you have to give up another chunk that is reserved for video memory (disregard if you have a GPU with it's on memory).

You may be having memory issues... The recommended Java configuration is:
Minimum ram = 2GB
Maximum ram = 4GB
permagen = 256MB

A ram upgrade probably would help a bit.

We need more info:

Specific OS and version (we already see it's 64-bit)
Java version (if it's newer than 1.8.0_11 there are known issues with MC) and size (32 or 64 bit)
 

epidemia78

New Member
Jul 29, 2019
1,810
-4
0
Binnies mod alone adds minutes to the load time. If you arent planning on messing with bees then you could just disable it.
 

Aaron5015

New Member
Jul 29, 2019
174
0
0
so it loaded,but it took forever to open a world...maybe i'll stick with flat worlds...IF IT WORKS.