Direwolf20 1.0.1 ID mismatch

Zuusu

New Member
Jul 29, 2019
10
0
0
After I updated the TConstruct jar on the server, what I could see was the only updated mod from 1.0.0, I got a mismatch on ID 335 and 79.

I don't get any other crashes or something, I'm pretty sure it's 1.0.1, in the launcher it still says 1.0.0 but I've upgraded the pack with TConstruct 1.5.2.1.

Anyone else having the same issue?
I went to the config of powercrystal/minefactoryreloaded but can't find anything about either ID 335 or 79 there.

Running the server on CentOS 5 64 bit.

The log is from my client though on W7.

335:
Code:
2013-12-12 12:21:29 [SEVERE] [fml.ItemTracker] Mismatched items : {335=(Item 335, Type net.minecraft.item.ItemBucketMilk, owned by Minecraft, ordinal 0, name null, claimedModId null, Item 335, Type powercrystals.minefactoryreloaded.item.ItemFactoryBucket, owned by MineFactoryReloaded, ordinal 8, name null, claimedModId null), 79=(Item 79, Type net.minecraft.block.BlockIce, owned by Minecraft, ordinal 0, name null, claimedModId null, Item 79, Type powercrystals.minefactoryreloaded.block.ItemBlockVanillaIce, owned by MineFactoryReloaded, ordinal 0, name blockVanillaIce, claimedModId null)}
 

Attachments

WuffleFluffy

New Member
Jul 29, 2019
403
0
0
I launched my the DireWolf20 client tonight which is now 1.0.1. However when I go my server provider 'CreeperHost', I cannot find the 1.0.1 mod pack to install, there are however TWO versions of the DireWolf20 pack with version 1.0.0, one with and one without tech support. I installed the one without tech support (thinking that they made a typo). When I tried to connect to the server I was told that the Mod 'Tinkers Construct' with mod TConstruct_1.6.4_1.5.1' was not present on the client and therefore could not connect.

When I check the mod list for what the server has installed I see that 'TConstruct_1.6.4_1.5.1' in the list.
If I check the client side for 1.0.1 I see that 'TConstruct_mc1.6.4_1.5.2.1' is in the list.

I've probably stuffed something up, I've reverted back to 1.0.0 for now on the launcher and deployed the the 1.0.0 pack on the server with the 'tech support' flag set to yes and all good again :)
 

thebatfink

New Member
Jul 29, 2019
19
0
0
After updating to 1.0.2 I also have the exact same ID conflicts.. 335 and 79. It asks if I want to continue loading. Should I be starting a new world?
 

Eyamaz

New Member
Jul 29, 2019
2,373
0
0
335 and 79 are vanilla IDs that are changed by MFR, which was added to the DW20 pack in version 1.0.1. It's a normal thing.