1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Crash on world load

Discussion in '[Archived] Tech Support' started by verid, Feb 22, 2014.

  1. verid

    verid New Member

    Anyone else getting this?

    Appears to be Biomes o Plenty's fault.

    I am running FTB Monster 1.0.10 but I don't think this problem is specific to this pack or version. This occurs in single player (SSP) immediately on world creation.

    Time: 22/02/14 3:45 PM
    Description: Ticking entity

    java.lang.NullPointerException
    at net.minecraft.util.ChatMessageComponent.func_111080_a(SourceFile:151)
    at biomesoplenty.handlers.TickHandlerClient.tickEnd(TickHandlerClient.java:47)
    at cpw.mods.fml.common.SingleIntervalHandler.tickEnd(SingleIntervalHandler.java:34)
    at cpw.mods.fml.common.FMLCommonHandler.tickEnd(FMLCommonHandler.java:141)
    at cpw.mods.fml.common.FMLCommonHandler.onPlayerPostTick(FMLCommonHandler.java:389)
    at net.minecraft.entity.player.EntityPlayer.func_70071_h_(EntityPlayer.java:407)
    at net.minecraft.client.entity.EntityClientPlayerMP.func_70071_h_(SourceFile:46)
    at net.minecraft.world.World.func_72866_a(World.java:2350)
    at net.minecraft.world.World.func_72870_g(World.java:2311)
    at net.minecraft.world.World.func_72939_s(World.java:2157)
    at net.minecraft.client.Minecraft.func_71407_l(Minecraft.java:1921)
    at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:910)
    at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:838)
    at net.minecraft.client.main.Main.main(SourceFile:101)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)
    at net.minecraft.launchwrapper.Launch.main(Launch.java:27)
     
  2. UniZero

    UniZero Popular Member

    Please post the full log to pastebin then link it here.
     
  3. Stoo42

    Stoo42 New Member

    Not sure if you resolved this, but I'm having the exact same issue this morning.

    I'm playing the DW20 pack, v1.0.18, we're running SMP.

    I was able to log in first thing this morning just fine, and I played for about 10 mins before having to log out. About 30 mins later I came back and got this error on login (client side crash).
    Since it worked first thing this morning, I've restored the server to last nights backup, and downloaded a fresh copy of the client modpack - it still fails with the same error. I find this extremely weird as this was the same state it was working in about 2 hours ago! In theory the server and client are both in a state that should work, except I get this error. Seems to be an error actually doing the tick on my player entity, but no idea why it started, or how to fix it, given that a backup that was proven as working before, suddenly is no longer working.

    Anyone else seen this, or know of a potential fix?
     
  4. ghostconnell1975

    ghostconnell1975 New Member

    I have also just started have this same issue.... was able to play an hour ago.. I logged out to restart my client and tried to log back into server and crashes on world load, have also tried to load a single player save and get the same issue
     
  5. Stoo42

    Stoo42 New Member

    Just had a couple of the other guys on the server test it, and they are having the same issue. So its either server side, or something with minecrafts auth service maybe?

    The reason I think it might be auth is because the stacktrace on the server has a bunch of stuff about the crypto service, and secure comms. One of the things that secure comms rely on, is having the time in sync (usually anyway). Both my client and the server are within milliseconds of each other, but if part of the login is the server checking with Mojang to verify my details, and because of daylight savings, or some other reason the time is out... This could be the comms failing.

    I'm about to turn off the Mojang checking temporarily to see if this helps - will post back when I have results.

    Yes I know its probably a long shot, but I'm struggling to find a cause for this one, when the exact same files were working fine earlier today. :-/
     
  6. Stoo42

    Stoo42 New Member

    Ok so this is harder than I thought to do with my particular setup.... going back to a really old world backup just to see if I haven't corrupted a backup somehow...
     
  7. oppositeZERO

    oppositeZERO New Member

    Can also confirm this on direwolf 1.0.18, Have myself and a few other people having the same issue.

    I've tried new mods/libraries folders, old world backup,s new worlds, mcpc, forge etc. Still having the same issue.

    edit: Can also confirm for Monster 1.1.0
     
    Last edited: Mar 9, 2014
  8. Stoo42

    Stoo42 New Member

    I'm starting to think this has something to do with daylight savings...

    This started happening about the time that parts of europe would have been going through daylight savings... While this is great if the world is in sync, the reality is some countries do their daylight savings differently, like Australia where I am.

    This still fits a bit with the fact it seems to be messaging and crypto thats failing - although its not great coding to use absolutes with datetime stuff, I would have thought that internally everyone would use GMT/UTC anyway.

    Again, I'm making some reeeeaaaally big assumptions and leaps in logic here. I could be completely on the wrong track. But struggling to see what else might have changed between a working copy, and a borked one.[DOUBLEPOST=1394329536][/DOUBLEPOST]You know what.. forget me, I'm ranting.. daylight savings for europe is different from the US anyway - so I was completely off track.... lol
     
  9. Stoo42

    Stoo42 New Member

    Ok so a bit more information:

    Starting a brand new single player world, it still crashes. So its definitely not world saves, or anything like that. 1.0.18 has been out for a few days now, and its been pretty stable for me. The only thing that has changed is the date and time (that I can see anyway). Unless there was a sneaky file update in the background that didn't alert us.

    One odd thing when I made the world, I alt tabbed away to check something while it was doing worldgen. When I came back I had the menu up, like it does when you've alt tabbed. It didn't crash until I clicked on "Back to game"... I'm not sure if this was just my timing, or if its a clue to whats breaking.
     
  10. Stoo42

    Stoo42 New Member

    Another update.

    If you disable BiomesOPlenty, and start a single player world.. It works just fine.
     
  11. PhilGoodInc

    PhilGoodInc New Member

    Is this problem affecting only us in Australia? Im having this issue too.

    EDIT:
    using DW20 with Galacticraft added on
    my crash report
    http://pastebin.com/HTSNnb9X
     
    Last edited: Mar 9, 2014
  12. jonnyo98

    jonnyo98 New Member

    having the same issue, cant connect to any direwolf20 pack servers. on pack version 1.0.16. Ive also confirmed that the issue is still there on other modpacks on other launchers
     
  13. kasper_tfg

    kasper_tfg New Member

    I am also having this problem and I am in Aus as well, but forgecraft guys don't seem to be having problems.
     
  14. ZippyBling

    ZippyBling New Member

    Same problem here, BOP was working fine this morning. I'm also in AU but all of a sudden it has given me this error.
     
  15. oppositeZERO

    oppositeZERO New Member

    I've had some players able to get on, and some not uncluding myself.

    I just tried using a vpn and was able to connect fine.

    Something strange is going on, perhaps we all have the same isp? Telstra anyone?

    Would be nice if we had an ip to the bop server or whatever to tracert.
     
  16. jonnyo98

    jonnyo98 New Member

    yeah, im using telstra adsl2+ here. I'm getting the crash
     
  17. Stoo42

    Stoo42 New Member

    Seems to be.... As soon as BiomesOPlenty is turned on, you cant get into any world, either new or old.

    It started almost right on midnight GMT/UTC if I had to guess.

    Just on the BOP IRC channel now, more Australians affected there also.

    I'll post again here if I get an update or a fix[DOUBLEPOST=1394334934][/DOUBLEPOST]
    I'm on Internode here - Fiber to the home, so its not completely telstras fault (for once) lol
     
  18. oppositeZERO

    oppositeZERO New Member

    See if you can get an address to whatever server it connects to so we can do some traceroutes to see where the issue is.

    As a VPN is 100% working for me.

    Cheers
     
  19. PhilGoodInc

    PhilGoodInc New Member

    Yeah ive got Telstra Ultimate Cable at home. Going to try connect with the vodafone wifi.
     
  20. Stoo42

    Stoo42 New Member

    Ok so we have a fix!

    In the BOP config files, there is one called main.cfg

    Change one of the lines to read:

    S:"Seen Version"="1.2.1"

    (It would have had null there before)

    Change this on the SERVER side, restart server, and people should be able to connect. :)
     
    un worry likes this.

Share This Page