1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Confused with Open Block Radio.

Discussion in 'General FTB chat' started by 0rthus, Feb 27, 2014.

  1. 0rthus

    0rthus New Member

    I have just updated to the 1.0.16 version of direwolf 20 1.6.4 beta. I am having issues adding radio stations to open blocks. I will be linking my config and attaching the forge log to this post to hopefully get assistance as to why the tuner cards are unaccessible.

    config: http://pastebin.com/3ZV9ri64
     
  2. SatanicSanta

    SatanicSanta New Member

    You have to trade the tuner cards with villagers, or find them in treasure chests.
     
  3. 0rthus

    0rthus New Member

    I am aware but shouldn't they also show up in NEI? Mainly because I do not see the tuner cards in NEI and the multiple villagers I spawn only sell jukeboxes.
     
  4. SatanicSanta

    SatanicSanta New Member

    No, them not appearing in NEI is normal.
     
  5. MacAisling

    MacAisling Popular Member

    To start, you have "http://http://" The tutorials I'm finding are using the numerical ip address format as well. I came across this tutorial yesterday:
     
    Not_Steve and Meirlean like this.
  6. rhn

    rhn Too Much Free Time

    Hehe I like this, you could pester the other people on the server with your bad music taste! Given the server owner added the stations to the config ofc.
     
  7. MacAisling

    MacAisling Popular Member

    Finally started messing with this myself. Looks like the OP's only problem should be the extra http. I, on the other hand, spent a couple hours before I finally figured out that java hates smart quotes.
     
  8. Shevron

    Shevron Well-Known Member

    Is it enough for the config to be server side, or do I have to distribute client side too?
     
  9. MacAisling

    MacAisling Popular Member

    I don't know, but I did come across a tutorial that covers both. Should be useful, even if he is using the Technic Launcher.

     
  10. Shevron

    Shevron Well-Known Member

    Popped it on server-side only .. waiting for it to restart while writing this.

    Will report back :D[DOUBLEPOST=1393529728][/DOUBLEPOST]Hmmmm can't find a radio in OpenBlocks.

    Running Monster 1.0.9
     
  11. Shevron

    Shevron Well-Known Member

    Apologies for multiple posts.

    I went through OpenBlocks.cfg, and although I can find the option to add the radio stations, I noticed that no block ID or item ID exits for either radio or tuner cards.

    Anyone know if this is on purpose?
     
  12. SatanicSanta

    SatanicSanta New Member

    @Shevron Radios and radio tuners were added in OpenBlocks v1.2.5, and I don't think Monster 1.0.9 has that version.
     
  13. Shevron

    Shevron Well-Known Member

    Aha! Thanks.
     
  14. el_freakyfrog

    el_freakyfrog New Member

    I'm running ftb magicfarm2 (2.1.3) with openblocks 1.2.5 and can confirm that both server and client side need the edited config file at least to load the radio station tuner crystal. I'm not sure however once the tuner crystal(s) have been found and placed in the radio (only one per radio) if everyone else needs the config file to at least listen to the radio station.

    suggestion:
    might be cool if there was a jukebox style radio where we can add multiple stations and choose one to suit our listening preference

    code i used to get it working

    # List any radio stations you want
    S:radioStations <
    "http://76.72.167.28:22084;Demonic Radio;Red"
    >
     
  15. Riva

    Riva New Member

    Hey I am using Direwolf20 1.6.4 version 1.0.19, with Openblocks updated to 1.2.6
    Now I have watch at least three guides on how to set up the radio stations that state on reboot the config should update in game and then tuned crystals should show up in Creative I have double checked the config aliment and made sure everything was exact.
    However this has not happened, I have tried redoing this config many times and still no results of them being generated in game, is there anyone who has had this issue and knows why it may not be working?
    Any suggestions on how to get this working
    Here is the radio section of the config in case there is anything wrong:


    ####################
    # radio
    ####################

    radio {
    # Add tuned crystals as loot in chests
    B:enableChestLoot=true

    # Maximum number of sources playing at one time
    I:maxSources=3

    # List any radio stations you want
    S:radioStations <
    "http://74.86.186.4:12120;181.FM - **UK Top 40**;Yellow"
    "http://67.213.214.248:9870;Party 181.FM;Yellow"
    "http://67.213.213.137:8012;A-1 Hits @ Party Rockers Radio;Yellow"
    "http://69.46.75.101:80;idobi Radio (idobi.com);Blue"
    "http://192.184.9.79:8006;CINEMIX;Blue"
    "http://205.164.62.15:10052;1.fm Love Classics;Blue"
    >

    # Tuned crystals merchant id (-1 to disable)
    I:radioVillagerId=6156

    # Should tuned crystals sell records too
    B:radioVillagerSellsRecords=true
    }
     
  16. Shevron

    Shevron Well-Known Member

    Uh ... I'm not VERY experienced at configs (my radios do work fine however), but with my limited experience I would change 2 things:

    1) put spaces after the semicolons.
    2) Simply the radio names. I'm sure the configs will not appreciate all the *, @, - and ).
    3) Why are you assigning the same colours to different radios?[DOUBLEPOST=1396870146][/DOUBLEPOST]Also, in creative mode, you should look up the tuner card by Radio name, not colour, which brings me back to the my original argument of simplify the radio names!
     
  17. Bartna

    Bartna New Member

    "http://74.86.186.4:12120;181.FM;- **UK Top 40**;Yellow"
    "http://67.213.214.248:9870;Party;181.FM;Yellow"
    "http://67.213.213.137:8012;A-1;Hits @ Party Rockers Radio;Yellow"
    "http://69.46.75.101:80;idobi;Radio (idobi.com);Blue"
    "http://192.184.9.79:8006;CINEMIX;Blue"
    "http://205.164.62.15:10052;1.fm;Love Classics;Blue"
    >

    you were missing the ; between the ip and name.

    on a side note since the 1.1.1 update mine no longer work so they may have changed it

    Example:
    http://46.23.64.98:8085;80's & 90's;White“
     
  18. Loufmier

    Loufmier New Member

    this is an off topic(like pretty much everything in this forum) question: what's the bloody point of having radio in minecraft, unless you want to annoy people on server with music they don't like?
     
    Hambeau and SatanicSanta like this.
  19. Riva

    Riva New Member

    I will give the extra ;'s a try and see if that helps as for the other parts to the name in the tutorials they worked fine and I have seen them used with those exact names on previous direwolf servers I have been on
    I haven ot changed any of the colours set in that pastebin as I did not want to change much to it in case that is the issue, I did search up the radio names which is why I said the config isn't working.
    But I shall see if it works now hopefully it does if not I will assume that perhaps the update has changed something in openblocks
     
  20. Shevron

    Shevron Well-Known Member

    There are some legit applicaations.

    For example: I once had a map on our multiplayer server that spawned new players in a house that took you through a museum-like tour of getting started with the basic stuff in FTB (if you never played modded MC before). The openBlocks radio adds very good ambience to a station of your choice.

    I wish they added speakers so you could hook up 1 radio to all rooms in the house instead of the few limited blocks around the radio itself. Already suggested it on the OpenBlock IRC channel. Mikee I'm looking at you :p
     

Share This Page