1. This section of the forums is now closed. You can post and answer support requests on the new support site here

Chunk rendering lag

Discussion in '[Archived] Tech Support' started by Juanitierno, Feb 6, 2013.

Thread Status:
Not open for further replies.
  1. Juanitierno

    Juanitierno New Member

    Hello!

    I have this issue where the farthest (not necessarily far) chunks are loading EXTREMELY slowly or not at all.

    Im quite sure the server is not lagging, because as soon as i move between dimensions or log in the minimap quickly fills with the terrain (and if the minimap fills i assume its because the client has all the chunks it needs).

    The thing is the chunks come into view quite slowly, and some might not even load at all. To be more specific minecraft seems to render chunks "closest first" but its like that process becomes slower and slower as there are more chunks loaded, until it takes a long time to load a single chunk or just stops.

    IS there something i can do to improve this? My computer is quite old, but im not experiencing framerate issues so i dont think its really struggling with the rendering...

    im using Optifine.

    Thanks!
     
  2. Velotican

    Velotican New Member

    In my experience the biggest limiter on world loading is the amount of RAM you give Minecraft. Try increasing that first.
     
  3. Juanitierno

    Juanitierno New Member

    Ill give it a try, but my computer only has 3gb total...
     
  4. Juanitierno

    Juanitierno New Member

    Just checked, the launcher wont let me set my memory above 1gb.
     
  5. Karimiri

    Karimiri New Member

    instal 64 bit java, and ingame set chunk loading to "smooth" instead "multi-core"(optifine is bugged)
     
  6. Juanitierno

    Juanitierno New Member

    Ill try the optifine setting (i think its alreado on smooth tho).

    the java option is not possible because my windows is 32 bits.
     
  7. rikailp

    rikailp New Member

    I'm having very similar issues which i just posted about in the optifine thread here: http://www.minecraftforum.net/topic...f-and-much-more/page__st__28220#entry20797056

    Did you get your issue fixed or are you still having problems as well?

    Edit: After some further research, i'm not so convinced this is related to optifine. I disabled optifine and am still having these issues... We aren't the only ones having the problem, either: See this thread...

    Second edit: And some more testing... This is also happening to me in singleplayer, as can be seen in this screenshot: [​IMG]

    (The #s along the top are just my recording software, left number is the FPS. Disabling the recording software makes no difference to the issue.)

    After waiting a while, some of it loads, but there's still plenty of unloaded chunks that should be loaded:
    [​IMG]

    Note: All the testing since disabling optifine has been done on fresh Mindcrack v8.0.1 install.

    Here's the console log from the session in the screenshot: http://pastebin.com/KFp2kkmk

    Also, using the default texture pack makes no difference, before someone suggests that. :p

    Third Edit: Noticed my java was out of date (1.7.0_05) so i updated it to latest (1.7.0_13), no change.

    Also tried downgrading to mindcrack v7, chunk-loading issues in the singleplayer instantly went away. Don't have a multiplayer server to test on, but i suspect the same is true.

    Yet another edit: Updated back to v8.0.1 and the issue has returned. It defnitely does seem to be effected more by proximity... If i fly around in creative close to the ground, some of the chunks do load quicker, but if i fly a fair ways above, almost no chunks load while i'm moving (some trees do). If i hover for a while in an area, most the chunks below will EVENTUALLY load, but it takes quite a while.

    If i drop out of the sky over an unloaded area, the chunks immediately below me will load right away, and the surrounding chunks will slowly load in at very reduced rate thats been described.
     
  8. Velotican

    Velotican New Member

    In the above case that actually sounds like intended behaviour, unfortunately. If vanilla doesn't do this (and that would be worth checking at this point) then it's probably ChickenChunks or Forge changing the default chunk loading behaviour.

    If you haven't updated Forge you could try that. Optifine also has performance options to force chunk loading or use alternative chunk loading techniques which might help.
     
  9. rikailp

    rikailp New Member

    As i mentioned on the optifine thread i linked, i did try a few newer versions of forge (518 and 524) to make sure it wasn't an optifine incompatibility. Neither seemed to have any effect.

    Both vanilla and mindcrack v7 don't act this way, this deviates significantly from vanilla chunk loading. I can intuit the difference, since i was a heavy vanilla player prior to getting into FTB.

    I've tried some of the performance options. They do make chunk loading act differently in v7 but seem to have little to no effect on v8.0.1.

    Going back to v7 seems to fix things instantly, even just converting the same world between the two, so i can only assume its something that changed between v7 and v8.0.1... Perhaps forge?

    I have noticed that chunk loading does seem to get even worse in chunks that have lots of stuff going on.
     
  10. Velotican

    Velotican New Member

    You might want to measure your tick rate. This mod is ideal for that purpose. It's a server-side only mod so it's easy to run on any setup.

    There are supposed to be 20 in-game logic "ticks" per second. If your tick rate is significantly less than that, it could be delaying chunk rendering exponentially; the game literally doesn't have the free processing time to load them.

    This is the only thing I can think of that could be causing the issue. If it is this, it means a mod in the game has had a massive drop in processing efficiency.
     
  11. rikailp

    rikailp New Member

    Just tried it on SSP, solid 20 TPS while i was watching the chunks load in extremely slowly, so i guess that isn't it.

    I don't think it's an issue with the actual chunk loading, as they show instantly on the minimap unlike when you normally see slow chunk loading.Its just the actual rendering of them that is extremely slow... if that makes sense?
     
  12. Velotican

    Velotican New Member

    I'm double-checking the ChickenChunks config.

    This is what my config looks like:

    Code:
    #ChunkLoader Configuration File
    #Deleting any element will restore it to it's default value
    #Block ID's will be automatically generated the first time it's run
     
     
    #Per player chunk limiting. Values ignored if 0.
    #Simply add <username>=<value>
    players
    {
    #Forge gives everyone 12500 by default
    DEFAULT=5000
    #For server op's only.
    OP=5000
    }
     
    #If set to false, players will have to be logged in for their chunkloaders to work.
    #Simply add <username>=<true|false>
    allowoffline
    {
    DEFAULT=true
    OP=true
    }
     
    #Set to false to deny a player access to the chunk viewer
    allowchunkviewer
    {
    DEFAULT=true
    OP=true
    }
     
    block.id=243
     
    #The number of ticks to wait between attempting to unload orphaned chunks
    cleanuptime=1200
     
    #The maximum number of chunks per chunkloader
    maxchunks=400
     
    #Set to false to disable the automatic reloading of mystcraft dimensions on server restart
    reload-dimensions=true

    Check yours and see if any of those settings are noticably different. I use a personal pack based on FTB and I get none of these issues so there must be an inappropriate setting used by FTB somewhere. This is at least the third time I've seen this kind of problem reported with FTB clients since the latest update.
     
  13. rikailp

    rikailp New Member

    That config matches mine precisely. I'll check and see if it differs from v7 at all when i have a chance.
     
  14. Velotican

    Velotican New Member

    Notably, forge.cfg and forgeChunkLoading.cfg were almost totally blank in earlier versions. They aren't anymore.

    Seems suspicious enough to look at!

    forge.cfg
    Code:
    general {
    # Controls the number threshold at which Packet51 is preferred over Packet52, default and minimum 64, maximum 1024
    I:clumpingThreshold=64
    B:enableGlobalConfig=false
    }

    forgeChunkLoading.cfg
    Code:
    ####################
    # Forge
    #===================
    # Sample mod specific control section.
    # Copy this section and rename the with the modid for the mod you wish to override.
    # A value of zero in either entry effectively disables any chunkloading capabilities
    # for that mod
    ####################
     
    Forge {
    # Maximum chunks per ticket for the mod.
    I:maximumChunksPerTicket=25
     
    # Maximum ticket count for the mod. Zero disables chunkloading capabilities.
    I:maximumTicketCount=200
    }
     
     
    ####################
    # defaults
    #===================
    # Default configuration for forge chunk loading control
    ####################
     
    defaults {
    # Unloaded chunks can first be kept in a dormant cache for quicker
    # loading times. Specify the size of that cache here
    I:dormantChunkCacheSize=0
     
    # Are mod overrides enabled?
    B:enabled=true
     
    # The default maximum number of chunks a mod can force, per ticket,
    # for a mod without an override. This is the maximum number of chunks a single ticket can force.
    I:maximumChunksPerTicket=25
     
    # The default maximum ticket count for a mod which does not have an override
    # in this file. This is the number of chunk loading requests a mod is allowed to make.
    I:maximumTicketCount=200
     
    # The number of tickets a player can be assigned instead of a mod. This is shared across all mods and it is up to the mods to use it.
    I:playerTicketCount=500
    }

    Note that increasing the chunk cache beyond 0 causes conflicts with ChickenChunks so leave that alone. Any other mismatches would be very interesting indeed.
     
  15. rikailp

    rikailp New Member

    Those are also both identical to v8, looks like i have 3 to compare to v7 now... :p
     
  16. AlanEsh

    AlanEsh New Member

    I was noticing this last night, on my first off-base exploration trip in a couple of weeks. I could barely navigate in a boat unless I just stared at the mini-map, for fear of running into un-rendered islands.
    Watching this thread in hopes you guys come up with something....
     
  17. rikailp

    rikailp New Member

    A user in another thread Velotican was helping out in also seemed to be having the same issue...
     
  18. Kipex

    Kipex New Member

    Experiencing the very same issue rikailp is decribing. I'm pretty sure it started after the v8 update aswell. Using Optifine, tried all settings and a couple different versions. Also tried without Optifine and got the same behavior. Highly annoying issue and I hope this gets fixed. Also compared all 3 of those configs above to my own and all identical for me aswell.
     
  19. Velotican

    Velotican New Member

    You could also try disabling ChickenChunks and see if it solves the problem. The more I look at this the more it feels like a conflict between two chunk loading systems. We're lucky that Railcraft isn't this fiddly. :p

    CChunks is fairly new and still has some quirks to iron out. Worse it hasn't been updated in a while now so it's possible that newer versions of Forge are breaking it.
     
  20. rikailp

    rikailp New Member

    For reference, here are the configs for the 3 files in a fresh install of v7:

    ChickenChunks.cfg:
    Code:
    #ChunkLoader Configuration File
    #Deleting any element will restore it to it's default value
    #Block ID's will be automatically generated the first time it's run
     
     
    #Per player chunk limiting. Values ignored if 0.
    #Simply add <username>=<value>
    players
    {
    #Forge gives everyone 12500 by default
    DEFAULT=5000
    #For server op's only.
    OP=5000
    }
     
    #If set to false, players will have to be logged in for their chunkloaders to work.
    #Simply add <username>=<true|false>
    allowoffline
    {
    DEFAULT=true
    OP=true
    }
     
    #Set to false to deny a player access to the chunk viewer
    allowchunkviewer
    {
    DEFAULT=true
    OP=true
    }
     
    block.id=243
     
    #The number of ticks to wait between attempting to unload orphaned chunks
    cleanuptime=1200
     
    #The maximum number of chunks per chunkloader
    maxchunks=400
     
    #Set to false to disable the automatic reloading of mystcraft dimensions on server restart
    reload-dimensions=true
    

    forge.cfg:
    Code:
    # Configuration file
    # Generated on 2/8/13 10:15 AM
     
    ####################
    # general
    ####################
     
    general {
        # Controls the number threshold at which Packet51 is preferred over Packet52, default and minimum 64, maximum 1024
        I:clumpingThreshold=64
        B:enableGlobalConfig=false
    }
     
     
    
    forgeChunkLoading.cfg:
    Code:
    # Configuration file
    # Generated on 2/8/13 10:16 AM
     
    ####################
    # Forge
    #===================
    # Sample mod specific control section.
    # Copy this section and rename the with the modid for the mod you wish to override.
    # A value of zero in either entry effectively disables any chunkloading capabilities
    # for that mod
    ####################
     
    Forge {
        # Maximum chunks per ticket for the mod.
        I:maximumChunksPerTicket=25
     
        # Maximum ticket count for the mod. Zero disables chunkloading capabilities.
        I:maximumTicketCount=200
    }
     
     
    ####################
    # defaults
    #===================
    # Default configuration for forge chunk loading control
    ####################
     
    defaults {
        # Unloaded chunks can first be kept in a dormant cache for quicker
        # loading times. Specify the size of that cache here
        I:dormantChunkCacheSize=0
     
        # Are mod overrides enabled?
        B:enabled=true
     
        # The default maximum number of chunks a mod can force, per ticket,
        # for a mod without an override. This is the maximum number of chunks a single ticket can force.
        I:maximumChunksPerTicket=25
     
        # The default maximum ticket count for a mod which does not have an override
        # in this file. This is the number of chunk loading requests a mod is allowed to make.
        I:maximumTicketCount=200
     
        # The number of tickets a player can be assigned instead of a mod. This is shared across all mods and it is up to the mods to use it.
        I:playerTicketCount=500
    }
     
     
    

    Literally the only difference i see between them and our current configs is this:
    Which according to this link does the following...
    Sounds promising, doesn't it? Though i'm not quite sure what to try from here...
     
Thread Status:
Not open for further replies.

Share This Page