1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

Cannot get NEI trashcan magnet or any utilities/functions in singleplayer?

Discussion in 'General FTB chat' started by Bigpak, Jul 6, 2014.

  1. Bigpak

    Bigpak Well-Known Member

    Hello everyone, Whenever I make a new singleplayer world for testing different things and new mods I am adding it will not appear with any functions, I have checked all the options in NEI to turn them individually on and off, global and just seperate world functions, I've checked the NEI.cfg with the lockedmode and it is set to -1 as monster normally has it. It does this with the default latest monster modpack.

    I have tried turning on cheats in the world creation thing, as these worlds are not important to me right now as they are for testing, still no luck. I've also tried making it creative in the world creation, not /gamemode c. That actually works but that is also fairly annoying that it is not working normally, does anyone have a fix? If I create the world in creative it allows me to use all of the options even when I change into survival gamemode or adventure or any other gamemode. It just will not work unless I generate the world in creative. Can anyone help?
     
  2. idjmleader

    idjmleader Well-Known Member

    I I think I had a similar problem. When you press E goto options click global goto inventory and if "w" is highlighted right click it I think. Then if you on a survival world it will toggle nei cheat mode back and forth. I think thats what you asked I know this used to not do that at all like two months ago.
     
    Last edited: Jul 6, 2014
  3. YX33A

    YX33A Over-Achiever

    Just need to make sure that when you want to do NEI changes in game you have it set to world mode. And it defaults to Global. Like, look away from the NEI Options GUI and it's Global again.(that is, leave it, not look away from your screen, though it wouldn't surprise me much if that caused that too)
     
    remclave and Padfoote like this.
  4. Bigpak

    Bigpak Well-Known Member

    Tried those, still cannot get it to work like that. It just refuses to work. I cannot get any of the utilities or gamemode options up. Any other ideas?
     
  5. KingTriaxx

    KingTriaxx Forum Addict

    Make sure that under the options, when you look at the option to enable/disable NEI, you hit the little global switch at the top right. Then on the left there should be a Grey W button. If it is, click on it so it's blacked down, and then click the global button again. You should now be able to properly switch modes.
     
    Padfoote and Bigpak like this.
  6. idjmleader

    idjmleader Well-Known Member

    press " o " ??
     
  7. Bigpak

    Bigpak Well-Known Member

    Thank you for explaining it better, I really appreciate the help <3 Thank you so much! I wish there was more I could do to thank you !
     
  8. idjmleader

    idjmleader Well-Known Member

    I said that to begin with I just did not go into depth.
     
  9. KingTriaxx

    KingTriaxx Forum Addict

    @Bigpack: You're welcome. I had to ask myself.

    @idjmleader: Don't worry, it's such a visual thing that it's difficult to explain.
     
    Padfoote likes this.

Share This Page