Additional Buildcraft Pipes (Teleport Pipes)

Meara

New Member
Jul 29, 2019
30
0
0
Hello,

I first want to apologize for asking this question if it has been asked and answered already. I have searched allover the internet to find a solution and just cant get to an answer or even a related problem.

Simply put: I can't install Additional Pipes into FTB. I keep getting a NullPointerException: null for the file net/kyprus/additionalpipes/AdditionalPipes. Here is the paste bin for the error straight from the FTB console.

For some strange reason though I feel like I'm missing something right in front of my face. I have made sure Forge, Buildcraft, and Additional Pipes are the latest versions for 1.4.2 Minecraft. I have tried even using a fresh install of FTB. Nada. I'm really just at my wits end on this.

Thank you in advanced! :p
 

Vauthil

New Member
Jul 29, 2019
1,493
0
1
First question: You sure that's the latest AdditionalPipes for 1.4.2 and not, for example, for 1.4.5?

Reading the error log, it's seeming like it's having issues finding things inside the file that should be there; I'm assuming you've re-downloaded and tried it again? I am also assuming you installed this as a normal /mods/ folder mod and all of that.

Kind of hard to diagnose with the data provided otherwise. Perhaps you could link us to where you got this copy of AdditionalPipes?
 

Meara

New Member
Jul 29, 2019
30
0
0
I hope this isn't braking any rules or any thing.
But here's the link to the download I had found on the Minecraft forums, and I'm using (well trying to) AdditionalPipes-2.1.3u17, witch states, on the page, that it is for 1.4.2.

I have downloaded it i think like 3 times, to make sure that it wasn't a corrupted file or any thing. but no matter what, with out fail, it is that error.

Edit: Forgot to mention that (maybe I'm seeing it wrong) That the file IS in fact there. For some ODD strange reason, it's not seeing it?
 

Vauthil

New Member
Jul 29, 2019
1,493
0
1
Nope, not breaking any rules; it's an unofficial port and so isn't going to be enthusiastic support, but it's valid enough (I'm using the 1.4.5 version on my 1.4.5 testbed right now in fact).

I think MiscPeripherals is causing some manner of foofy conflict now that I read into it. It's trying to pull data related to AdditionalPipes since it sees it installed, but it's not pulling it from the right location. I'm guessing both mods are too "must have" to choose between cutting one?
 

Meara

New Member
Jul 29, 2019
30
0
0
Tested Taking out MiscPeripherals, and DING, ya nailed it.
Didn't think that would have been the case as since MiscPeripherals worked fine on it's own.
No, i'll cut MiscPeripherals as since the only thing i used was chunk loading turtles any way, I might as well just place the world anchors my self.
Maybe they will agree with each other in the future then.

Thank you so much for your help! :D
 

xmikerangerx

New Member
Jul 29, 2019
1
0
0
Hey im new and i was having the same problem and i was wondering where you would find this misc peripherals in within the files of the modpack thanks
 

Meara

New Member
Jul 29, 2019
30
0
0
Hey im new and i was having the same problem and i was wondering where you would find this misc peripherals in within the files of the modpack thanks
It's not in the mod pack by default, you must have installed it your self. If you are truly having the same issue.
 

Mageleon

New Member
Jul 29, 2019
107
0
0
i think its weird how this thread went from Additional Buildcraft Pipes which i extremely need :( to turtles lol