1. Please make sure you are posting in the correct place. Server ads go here and modpack bugs go here

A (hopefully) simple Big Reactors question

Discussion in 'General FTB chat' started by Ieldra, Jul 6, 2014.

  1. Ieldra

    Ieldra Popular Member

    So now I've built myself a Big Reactor for my intermediate power needs and to help me gather resources and build the infrastructure for the ReactorCraft versions. I have it running and supplied nicely, but I have one small problem: I have two access ports, one configured as inlet and one as outlet. I figured I could use the outlet version to pump the wasteproducts out. However, the wasteproduct (cyanite) instead materializes in the access port configured as inlet. The same access port correctly accepts uranium/yellorium ingots as fuel. What am I doing wrong?

    BTW:
    This is (for now, and not for long) a passively-cooled reactor with 5x4 fuel rod blocks (5 control rods) cooled with cryotheum, and it outputs 12 KRF/t while consuming one uranium/yellorium ingot in 10 minutes. Is that an acceptable efficiency for a passively-cooled reactor?
     
  2. Wagon153

    Wagon153 New Member

    Okay, let's get the obvious stuff out of the way. Is the outlet full?
    Also, best efficiency can be obtained by cooling with resonant ender with cryotheum between the rods.
     
  3. Ieldra

    Ieldra Popular Member

    It is empty. I had the reactor running only for an hour or so when I noticed this. 5 cyanite ingots had appeared in the inlet, however.

    Thanks, I'll switch to that some time.
     
  4. Wagon153

    Wagon153 New Member

    Alright, next up. Have you tried switching the ports to do the opposite?
     
  5. Ieldra

    Ieldra Popular Member

    Tested again. It works now. I may have pushed the "eject waste" button in the interface of the inlet port when I tested this before I automated the waste ejection. It appears that pushing the "eject waste" button on the outlet fixed things. Odd, that. I thought these buttons were only for manual ejection.

    Anyway, problem solved.Thanks.
     
    Wagon153 likes this.
  6. GreenZombie

    GreenZombie New Member

    It was my reading of the current big reactors code that waste products were distributed to input/outlet ports in instantiation order, not in regard of their settings. So, basically, the first port placed will be the port that gets the initial waste. If you have the patience to wait for that to fill with 64 cyanite ingots, then the next port will start to fill.
     
  7. Narc

    Narc New Member

    The cyanite outputting to the wrong place is a known bug in current BigReactors; a suggested workaround is to make your inlet port "eject fuel" and keep just one ingot of yellorium in there (in the output slot of the inlet port, to be clear) -- the cyanite won't be able to replace the yellorium, so the reactor will just skip over to the next port, which will be the outlet.

    Just swapping modes on the ports has been reported not to work reliably, presumably because the instantiation order (when, e.g. the server stops and starts back up again) is likely to be fairly random.
     
  8. GrimJahk

    GrimJahk New Member

    Sorry to Necro this thread, but I'm having a similar set of issues that the above suggestions have not resolved.

    My reactor WILL NOT eject cyanite ingots. Not manually, not automatically, not ever.

    I'm running the DIrewolf20 1.7.10 FTB Pack (1.0.2 build) on an OSx server

    I built a 7x7x7 passively cooled with resonant ender (but the coolant seems to make no difference) 5 fuel rods, I had the reactor configured with either one or two fuel ports (no change). I have a Rednet controller Adjusting the Rods proportional to the reserves of power, I have a single power tap.

    When the chamber fills with waste the rods turn blue, still cannot force an eject… In order to clear the waste (when I had two fuel ports) I had to turn off the reactor and "eject Fuel" to get the last of the Yellorium out along with switching the function of the ports between input and output… eventually the reactor would get confused and the rods would change from blue to clear, but I still never got any of the waste… it would simply vanish.

    I have had success with Big Reactors in the past, I am familiar with their operation (Agrarian Skies and ME^4) this seems to possibly be an issue with the mod pack, as I'm hosting this, I'd like to get it working properly
     
    Last edited: Feb 2, 2015
  9. GrimJahk

    GrimJahk New Member

    Additionally, I cannot select the option to NOT automatically eject waste. It seems to be locked into "Automatically eject" (which it doesn't do)
     
  10. rhn

    rhn Too Much Free Time

    Are you sure you have not clicked the "Do not Auto-eject waste" button on Controller GUI?
     
  11. GrimJahk

    GrimJahk New Member

    As I posted about 30 sec before you did, I cannot toggle the Auto-Eject option

    [​IMG]
     
  12. rhn

    rhn Too Much Free Time

    Sounds like it doesn't think there is any valid access ports to put it into. Have you tried breaking and replacing both access ports?
    And how much waste are we talking about you wanting it to eject? it cannot eject it before there is at least one ingot.
    From the picture it looks like an extremely small reactor. So it might have to fill up a LOT before a whole ingot can be formed.
     
  13. GrimJahk

    GrimJahk New Member

    As I said above, I'm not new to Big Reactors… I successfully built a 3 turbine active-cooled reactor system in the past, it is not behaving as I expect in this pack… That being said...

    Fighting with PRC I managed to get the reactor to dump the cyanite!! Setting second PRC function "Randomizer (digital)" I set Q: I/O D (Green -> Dump Waste)

    Viola! Waste dump!
     
    Last edited: Feb 2, 2015

Share This Page