Open 1.7.0: FTB Infinity - Mystcraft issue, times out user upon logging in.

Discussion in 'Infinity Evolved 1.7.10' started by TehMuffinMoo, Jul 6, 2015.

  1. TehMuffinMoo

    TehMuffinMoo New Member

    Version:
    1.4.1

    What is the bug:
    I'm experiencing an issue after updating my server to FTB Infinity 1.7.0. - Same/similar issue as posted here: http://forum.feed-the-beast.com/thr...d-now-cant-connect-to-server-timed-out.98461/

    We disable Mystcraft and it has been disabled since prior to launching the updated modpack. The server launches absolutely fine, no errors or issues notes in the logs - However, when it comes to a player logging in, their client will hang for a moment and then it will time them out.

    Reading through the post linked above though, I don't understand how mystcraft will need to run anything - When it's never actually been enabled on this server? Unless the client requires the server to complete the profiling whether or not it was ever enabled.

    Mod & Version:
    mystcraft-1.7.10-0.11.13.00

    Paste.feed-the-beast.com log:


    Can it be repeated:
    This issue can be recreated by enabling Mystcraft client-side and disabling Mystcraft server-side.

    Known Fix:
    If you disable Mystcraft on the Client machine(Already disabled on the server) it will allow it to log on.

    Unfortunately, for servers like my own where Mystcraft needs to remain disabled on the server, we can't ask all of our existing players to disable mystcraft in their clients - so we've temporarily rolled back to v1.6.2 which works absolutely fine.

    ~Edit - Correcting Mod & Version
     
    Last edited: Jul 6, 2015
  2. Chunk_TV

    Chunk_TV New Member

    This is the same issue I'm facing. It has all but entirely killed my community, as our server was down for two days updating and then reverting back to 1.6.2. Not a single user has come back online yet. --(side note: I learned some better FTP practices...)

    One other thing to note. I was never actually able to start a server on any of my testing systems or on the main 16gb hosted server UNLESS Mystcraft was disabled anyway. So yeah we're really screwed here. Either it's either enable it and it just doesn't run, or disable it and have the community confused as heck as to why they can't join.

    It's really frustrating because I see plenty of other servers have come back online and perfectly joinable....

    I personally tried every fix I could find or even think of:

    Just enabling Mystcraft - nothing
    Disabling INpureCore and enabling Mystcraft - nothing
    Tearing the Guts out of the Mystcraft mod jar but still leaving it - nothing
    Tearing the Guts out of the Mystcraft mod jar but still disabling it - nothing
    Renaming the internal Mystcraft com folder from xcompwiz to HORRIBLEPROGRAMMER and leaving enabled - nothing (actually it was something a bit more explicit)
    Renaming the internal Mystcraft com folder from xcompwiz to HORRIBLEPROGRAMMER and setting disabled - nothing

    Leaving Mystcraft disabled and setting disabled client-side - works...
    ^^ It's really embarrassing to even contemplate trying to ask our community to do this, especially when there is a fix out there.

    --EDIT: I just thought of something, possibly taking the old version of Mystcraft and renaming it to the new version. Idk, I'm literally trying everything at this point... Will report on this thread if we get anything.
     
    Last edited: Jul 6, 2015
    TehMuffinMoo likes this.
  3. TehMuffinMoo

    TehMuffinMoo New Member

    Good to know Chunk_TV! - I'm glad it's definitely not just me!

    Hopefully one of the FTB devs will pick this up, I believe it's been reported by a few other members too - including a few guys in the IRC chat.

    I've rolled back to v1.6.2 and put a notice on the MOTD to say it's remaining on 1.6.2 until this is resolved. I'm trying to keep my community updated on our forums but I've not seen anybody else speaking about this issue.

    Speak up guys! :)

    ~Edit - Good spot! I've corrected the version, I was looking at the wrong folder! :p
     
    Last edited: Jul 6, 2015
  4. darkcamo12

    darkcamo12 New Member

    I have had the same issue but before updating we tend to run a test server to make sure out setting don't conflict anywhere

    But what is happening from things I have been able to find is that the clients version of mystcraft is trying to find and connect to the one that should be on the server and since a lot of us tend to remove it, it fails and causes the client to disconnect
     
  5. Chunk_TV

    Chunk_TV New Member

    Right, but, well I guess what neither of us mentioned is. We're not "removing" it as it were. We're using the normal demonstrated method of disabling it. Which would be adding .disabled to the filename after .jar, so, example mystcraft-1.7.10-0.11.13.00.jar.disabled << This method of disabling should not affect the clients whatsoever. As the versions / files match up, but the addition of .disabled scrambles it from actually running.
    ^^ I guess I assume this is what Muffin is doing as well, though I should only speak for myself.

    Maybe it's also important to note that I personally am using a Cauldron system, though, I'm pretty sure this is the standard.
     
  6. darkcamo12

    darkcamo12 New Member

    .Disabled does the same thing as removing it as Java skips over it as it is neither a .rar .jar or a .zip and won't send a packet to the client to disable it, so the client will still look for it causing the error on connecting

    And I use cauldron as well but in saying that my fix was easy

    Put mystcraft back in an use minetweaker to remove the items from being crafted and being shown in NEI, and make sure you are using the version of cauldron with forge version 1448 or above
     
  7. Chunk_TV

    Chunk_TV New Member

    I have a working test server now after some messing around. Also, I wish someone would have pointed me to KCauldron, as I'd never heard of it. I had a sneaking suspicion that it had a little something to do with an incompatible forge version after I finally recognized the similarities in version numbers.

    It's super late for me now, and I'm way too intoxicated to fully describe it all. First thing tomorrow I'll post the full description of what I've done thus far. It appears at this point all that is left to do is block the Mystcraft stuff via either minetweaker or plugins, as camo suggests.


    --Screw it, I'll attempt it.

    I searched the net for a 1448 cauldron. Ran through a bunch of crap and then stumbled on KCauldron, mirrored on Yive's Mirror: http://tcpr.ca/cauldron
    KCauldron appeared to have a 1448 version ( I just grabbed the latest 1448 one ), as well as a MobiusCore Fix (MobiusCore-1.2.5-KC.jar) at the top of their page, which I also downloaded.

    Setup the server as you would normally do for cauldron ( drop libraries and jar, rename jar to your specific use, blah blah ).

    Then, ( It took a bit of trial and error but I think this is right ) drop the MobiusCore-1.2.5-KC.jar into the mods folder and remove MobiusCore-1.2.5_1.7.10.jar.

    X Set Opis-1.2.5_1.7.10.jar to .disabled --EDIT: Pretty sure this is unnecessary, IDK what was wrong to point me to do this. I think I already had the KC MobiusCore, though I may have had it disabled at first.

    From here, just leave Mystcraft enabled and you'll have to block it either via MineTweaker or with plugins.

    For me, the server runs, and is fully joinable though that's only on the base testing system with none of my plugins or anything implemented again. Just to specify.

    ^^^ FYI This is as far as I am personally right now. Will be testing blocking the Mystcraft stuff and running a full version sometime tomorrow.

    ...and now I sleep. xD
     
    Last edited: Jul 10, 2015
  8. Mickimoo2

    Mickimoo2 New Member

    Yeah this is still an issue, here is my client log as it actually shows a problem I do not understand. I have been using kcauldron for some time now and from the looks of it, it may be a fluid registry problem:

    http://paste.feed-the-beast.com/view/92d27525

    Mystcraft is even disabled along with RFTools.
     
  9. TehMuffinMoo

    TehMuffinMoo New Member

    You're right in saying I'm a cauldron user too. Everytime I update to a new version of forge with a new modpack version I always upgrade the version of Cauldron too - Currently I'm running on kCauldron 1448 too.

    I also have used the MobiusCore fix as otherwise the server will crash when running OPIS.

    I'm a little concerned about just enabling mystcraft though, even if it is blocked by other plugins/mods.. This is more of a workaround than a fix - And this still needs to be fixed in the modpack.

    Great suggestions though, and atleast there's a temporary workaround until it's fixed!
     
  10. Mickimoo2

    Mickimoo2 New Member

  11. darkcamo12

    darkcamo12 New Member

    If you use minetweaker to block mystcraft items there is not way for them to use it as it uploads those configs to the remote user and forces it's to be disabled

    Your choices are limited atm it's either stay on the older version of infinity, ask all you members to disable mystcraft before they join or enable mystcraft and block all its items and blocks
     
  12. Chunk_TV

    Chunk_TV New Member

    Yeah, I think camo's right. It looks like that's all we've got right now. It appears even the big syndicates like DevCo are doing exactly this too. At least from what I gathered doing some snooping around and asking questions of their players and staff...
     
  13. TehMuffinMoo

    TehMuffinMoo New Member

    I've ended up giving in and just enabling Mystcraft and using MineTweaker to remove the recipies. This is working after tweaking some plugins that Mystcraft didn't want to play nice with!

    I've seen they have just released a 1.8.1 beta - I'm going to be booting up the dev server and giving this a test to see if the problem still exists in the new version.
     
  14. Mickimoo2

    Mickimoo2 New Member

  15. TehMuffinMoo

    TehMuffinMoo New Member

    I'm going to be testing this pack tomorrow whilst I'm working from home, I'll be able to update you then.

    So far so good with the current server though. Some of my plugins occasionally throw errors relating to Mystcraft but nothing major and it's not breaking it- so I'm just ignoring those! Mainly occurs only during world gen though, then they settle down and may not see any for a day or two.
     
  16. Mickimoo2

    Mickimoo2 New Member

    @TehMuffinMoo Will be looking forward to it, cant wait to get rid of the resource intensive mods... I do love the world folder spam xD
     
  17. Chunk_TV

    Chunk_TV New Member

    ARRRRRGH. I still apparently can't run anything... it's citing Invalid LOC Header on the mods... I've tried a million more things as well as a suggestion from a dev on a top listed server, to enable chicken chunks and set its last setting in cfg (related to mystcraft world loading) to false.

    One friend watching me work on this was suggesting that my server needs to be running Java 8... but as far as I know, this shouldn't matter at all. Server is linux based, that I know for sure...

    None of this makes a bit of sense to me.

    [00:10:48] [main/ERROR]: CodeChickenCore: Failed to read jar file: appliedenergistics2-rv2-stable-9.jar
    java.util.zip.ZipException: invalid CEN header (bad signature)

    This is from another previous attempt. It cites this on lots of initial start mods and then just crashes... On this attempt it cites CEN header, on the current attempts it cites LOC header...


    Server runs fine in testing on my computer. As soon as it hits the hosted server... No function.
     
    Last edited: Jul 19, 2015
  18. Mickimoo2

    Mickimoo2 New Member

    @Chunk_TV doesn't have to be java 8 as I got it working in java 7 then updated to java 8 as it doesn't have perm gen :D . But then again I never got that error.
     
  19. Chunk_TV

    Chunk_TV New Member

  20. D.V

    D.V New Member

    I have the same issue with my custom FTB Infinity (i would try GT5 unofficial with Forge 1492) => The server launch perfectly (no crash) but when i try to join the server.... Timed out :/

    I disable mystcraft server & client side : same thing, timed out... Same with a new world !
     

Share This Page