Mac 1.6.4 DW20 Closes during launch

xasuma

New Member
Jul 29, 2019
9
0
0
Hi, '
I am attempting to play ftb direwolf20 1.6.4 but as the title says, the launcher closes mid-launching.
I have had this issue in windows and succesfully fixed it by changing java versions and allocating it more ram.
However in this mac, I have java version 1.6.0_65 and I am unable to upgrade to java 7 since I have Mac OS X version 10.6.8 and java 7 needs 10.7.3 for it to run.

I am running on a 64-bit desktop-mac. And I have tried allocating up to 3.5 gb of ram to the launcher.
I am unable to upgrade java versions, so I am lost on this one.

Thank you in advance!
 

BlootZ

Active Member
Jul 20, 2013
3
0
27
When you senter launcher go to Options > Advanced options and in Additional Java Parameters and write this: -Xmx2048M -Xms2048M
This will make that when you launch any modpack it will run with 2 GB of RAM
If you want to run with 3 GB write this: -Xmx3072M -Xms3072M
 

lavarthan

New Member
Jul 29, 2019
2,437
0
0
You should be using Java 7 with the 1.6.4 packs. Be sure to get the 64bit version of Java. I've never heard of Java 7 needing a later version of MacOS to run. Where did you read that. I do not have a Mac, but if I were you I'd back up anything important, always best to be careful, and try installing it anyway.

Could you post a console log to pastebin.com Go into the options part and check the boxes that say 'Show Console?' and 'Re-open launcher after exiting minecraft' Now the launcher should reopen and allow you to see the console error after minecraft closes. Click on the 'Paste my log to pastebin.com' button on the console, this will create a link at the bottom of the console that you provide to us so we can see your console log and the error. If the button does not work please manually copy the console to pastebin.com and provide the link it gives you. If the console does not reopen check your mod pack folder for an error (text) file. Once found please manually copy the info to pastebin.com and provide us the link that it gives you. Look here for more info on the logs and pastebin.
 

Yosomith

New Member
Jul 29, 2019
344
0
0
You should be using Java 7 with the 1.6.4 packs. Be sure to get the 64bit version of Java. I've never heard of Java 7 needing a later version of MacOS to run. Where did you read that. I do not have a Mac, but if I were you I'd back up anything important, always best to be careful, and try installing it anyway.

Could you post a console log to pastebin.com Go into the options part and check the boxes that say 'Show Console?' and 'Re-open launcher after exiting minecraft' Now the launcher should reopen and allow you to see the console error after minecraft closes. Click on the 'Paste my log to pastebin.com' button on the console, this will create a link at the bottom of the console that you provide to us so we can see your console log and the error. If the button does not work please manually copy the console to pastebin.com and provide the link it gives you. If the console does not reopen check your mod pack folder for an error (text) file. Once found please manually copy the info to pastebin.com and provide us the link that it gives you. Look here for more info on the logs and pastebin.
Just as a point of note: Java 7 requires an Intel-based Mac running Mac OS X 10.7.3 (Lion) or later, taken from the java download page.
 
  • Like
Reactions: lavarthan

lavarthan

New Member
Jul 29, 2019
2,437
0
0
Just as a point of note: Java 7 requires an Intel-based Mac running Mac OS X 10.7.3 (Lion) or later, taken from the java download page.
Oh good to know. I go straight to the download page. I still hope that there is something that can be fixed so he can run the 1.6.4 packs.