Closed 1.3.4: [1.4.0] Infinity - Massive spikes CPU/RAM

EchoingZen

New Member
Jul 29, 2019
351
0
0
Version:
1.3.4

What is the bug:
I am getting massive spikes of both RAM and CPU usage.

After about 5 to 10 minutes of play it will go to 70% mem usage, creep up 1% per second, hit 99% and then freeze for a second and restart to 71% and repeat the process all over again. This will eventually result in 100% mem usage making Minecraft unplayable.

I disable OptiFine and Fastcraft and was still getting the same issue. On a hunch I thought it could be related to Mystcraft's new profiling system. I disabled Mystcraft and the problem vanished.

Mod & Version:
mystcraft-1.7.10-0.11.3.00.jar

Paste.feed-the-beast.com log:


Can it be repeated:
* Creating a new world results in the same issue.

Known Fix:
 

EchoingZen

New Member
Jul 29, 2019
351
0
0
that's known and there even was an announcment for that issue :)
There is, but that was back on the 25th of March and they had said they are going with a previous version until it's resolved. This pack is now using the latest version, which is why I was reporting it. It looks like the problem still isn't resolved.

"NOTICE: Until this issue is addressed, FTB and Direwolf20 have decided to roll back Mystcraft versions within our newest pack updates. Infinity 1.3.4 and Direwolf20 1.7 1.2.1 will contain additional mod updates, fixes, etc. sans the latest Mystcraft release. "
 

Chaos_Legion

New Member
Jul 29, 2019
3
0
0
How did you get optifine working with ftb and fastcraft and stuff ? I thought it is impossible and very expensive.
 

EchoingZen

New Member
Jul 29, 2019
351
0
0
Just make sure you have the latest version of optifine and it should work just fine. If you get texture flickering, just turn off fast math in the options.
 

ScottulusMaximus

New Member
Jul 29, 2019
1,534
0
1
There is, but that was back on the 25th of March and they had said they are going with a previous version until it's resolved. This pack is now using the latest version, which is why I was reporting it. It looks like the problem still isn't resolved.

"NOTICE: Until this issue is addressed, FTB and Direwolf20 have decided to roll back Mystcraft versions within our newest pack updates. Infinity 1.3.4 and Direwolf20 1.7 1.2.1 will contain additional mod updates, fixes, etc. sans the latest Mystcraft release. "
You've answered your own question, they didn't but it in the 1.3.4 release, they have in the 1.4.0 UNSTABLE pack.
 
Jul 29, 2019
1
0
0
Aye I just upgraded from 1.3.1 to 1.4.0 and within 10 minutes of playing had the exact same issue as OP. The game just locks up every 5 seconds until you restart the client.
 

Darkmagi

New Member
Jul 29, 2019
7
0
0
Just downgrade your mystcraft-1.7.10-0.11.3.00.jar back to mystcraft-1.7.10-0.11.0.00.jar and the lag will be gone it's a pain to do especially if it's a large server but it works.
 

ScottulusMaximus

New Member
Jul 29, 2019
1,534
0
1
Just downgrade your mystcraft-1.7.10-0.11.3.00.jar back to mystcraft-1.7.10-0.11.0.00.jar and the lag will be gone it's a pain to do especially if it's a large server but it works.
OR
you could wait 10min before logging in to the server and wait for the profiler to finish...

The profiling does hurt though, a LOT
 

Darkmagi

New Member
Jul 29, 2019
7
0
0
The lag on mine continued even after profiling I have a lot of rftools worlds though but it still kept lagging went ahead and downgraded and all is good.
 

ScottulusMaximus

New Member
Jul 29, 2019
1,534
0
1
The lag on mine continued even after profiling I have a lot of rftools worlds though but it still kept lagging went ahead and downgraded and all is good.
Hmmmmm, yeah I'm seeing this...

EDIT: a restart after profiling seems to have cured it but will update if anything changes.
 

tinussky

New Member
Jul 29, 2019
1
0
0
Easily solved by downloading the latest mystcraft from curseforge, it now displays a msg saying it is baking cake. And it is a lot faster. Now only using 2gb instead of over 3gb.