Open 1.2.0: Severe lag when Y>=190 on ocean

Precatou

New Member
Jul 29, 2019
8
0
0
Version:
1.2.0

What is the bug:
I'm not sure what mod causes this because I can't repeat this with a vanilla 1.7.10.

I have practically untouched 1.2.1 server running on i7 based desktop. I use my other desktop (even faster i7 + proper display adapter) to run the client.

I get around 400fps while flying above an ocean, but as soon as I reach the height of 190 I notice the FPS starts to go down until it becomes 0 and naturally the game becomes unplayable. It takes about 15-30 seconds for the game to slow down when I reach the height.

It is also worth to point out that I don't have similar laggyness above the ground, so I suppose there's something in the water that causes the issue.

Also, when I'm experiencing the horrendous lag, I can simply drop down to 189 and the FPS jumps to the hundreds.

I noticed the problem after building something pretty tall in the water.

Mod & Version:


Paste.feed-the-beast.com log:


Can it be repeated:
1. Set up a fresh server in creative mode.
2. Fly around to locate an ocean and when you found one then fly on it so that there's plenty of water around you.
3. Fly upwards to reach height of at least 190. It doesn't matter if you look up or down or forward.
4. Wait 15-30 seconds. You should notice how the fps starts to drop down and eventually it drops to zero.

Known Fix:
 

RedDragonGecko

New Member
Jul 29, 2019
11
0
0
Ok so I've narrowed it down a bit.

Squid; spawning in the thousands when you are 124+ blocks from the surface of the water.
I would assume this has something to do with forge.
 

Wekmor

New Member
Jul 29, 2019
939
0
1
Ok so I've narrowed it down a bit.

Squid; spawning in the thousands when you are 124+ blocks from the surface of the water.
I would assume this has something to do with forge.
I don't think it's forge.
Seeing as all the other mobs despawn, only squid can, and so will spawn.
It's just a minecraft problem I guess, but since you won't ever be over y=190 in vanilla, you won't notice it as much there...
 

RedDragonGecko

New Member
Jul 29, 2019
11
0
0
Doesn't happen in vanilla, I just tested it. I does however happen in Infinity and Direwolf20.
Those are the ones I've tested so far.

Its easy to do, load up minecraft. Start a world in creative. fly over an ocean at aleast 188+
 

RedDragonGecko

New Member
Jul 29, 2019
11
0
0
Okay, I've discovered the source of the lag.
Forge(?) rapid spawning/despawning of squids while 124+blocks above the surface of an ocean while having the Hats mod installed.

So for now, disabling the Hats mods (and hat stand as it will error otherwise) fixes the lagging problem for now.

The squid problem needs to be looked further in to though.
 

Precatou

New Member
Jul 29, 2019
8
0
0
Yes, I can confirm that the hats-mod has something to do with this. I suppose the squid spawning/despawning is definitely the real source of the problem. Hats mod simply acts as an amplifier in the issue.