Closed 1.2.0: Chunk unload issue in 1.3.0 & 1.3.1

MrDlor

New Member
Jul 29, 2019
75
0
0
Version:
1.2.0

What is the bug:
We noticed a big server lag issue yesterday after updating to 1.3.0 and even today with 1.3.1

After moving around in the nether and leaving the dimension a bunch of chunks won't unload correctly which causes the nether to lag the server.
As long a person is actually in the nether it doesn't lag at all , but when nobody is in it the server TPS goes to hell.

We did not add any mods we only removed the following mods due to bad history or cause they felt a bit spammy for the server:

AromaCore , AromaBackup , EnderZoo , Headcrumbs , Opis , Twilightforest.

The issue gets very clear when monitoring the /chunkloaders window which shows the areas loaded in each dimension.


(On the actual server the nether ms spikes up to 70-100 ms when nobody is in the nether. This is a picture from singelplayer to show the problem of)

The picture above was made in a newly generated world and has the same issue just in a smaller scale (still , double the ms then the dimension with a actual player in it)

The nether will unload completely eventually if there are absolutely no chunk loaders what so ever. With chunk loaders / thermic pumps / spot loaders ect those bugged chunks will stay loaded for ever even if the chunk loader is thousands of blocks away.

We rolled back to 1.2.1 and the issue is completely gone. So it must be some change in 1.3.0 & 1.3.1 :(

Mod & Version:


Paste.feed-the-beast.com log:


Can it be repeated:
Yes.

I made a fresh install of 1.3.1 removed the mods named above.
Opened up the /chunkloaders window and went into the nether and back.
Same issue on server & singelplayer.

Not happening with 1.2.1

Known Fix:
No fix known
 

stardustrider

New Member
Jul 29, 2019
13
0
0
Is it a specific mod causing this? I'm having this exact issue with my private pack, and it's infuriatingly annoying in that it's almost impossible to pinpoint the culprit without doing a very time consuming process of elimination.
 

Rebirth Gaming

New Member
Jul 29, 2019
360
0
0
Our modpack is encountering the same issue. We will conduct troubleshooting on our end to help isolate the issue. To help this process along, I have posted my pack's modlist here. Maybe we can compare mods and make a list of what we all have in our packs, and start from there.

We don't have any exact details to report, as we just encountered this today, and, after having read this post earlier today, I now know I'm not alone. Literally, our server's tps was down to 1tps. One of our players suspected it was their ender pump. I entered the nether to see if map writer would show any high median time/entity chunks. However, immediately upon entering the nether, the tps shot back up to 20.

Our temporary solution (hopefully it works) is to anchor the nether.

Modlist:

http://pastebin.com/s17ScdR3
 

tfox83

New Member
Jul 29, 2019
1,588
0
0
I still haven't had time to look into this, but yea I have no idea at the moment, hopefully I can dig into it tomorrow and see what's causing the issue.
 

stardustrider

New Member
Jul 29, 2019
13
0
0
With this being reported as an issue in Infinity 1.3.0+, I've compared the updated mods in it, Rebirth Gaming's and my own, to come up with a shortlist of potential causes:

Agricraft
Bibliocraft
Big Reactors
Blood Magic
Buildcraft
CoFHCore
ComputerCraft
Forbidden Magic
Jabba
MineFactory Reloaded
MobiusCore
Opis
Pam's Harvestcraft
Redstone Arsenal
Tinkers Construct
Thaumic Tinkerer
Thermal Dynamics
Thermal Expansion
Thermal Foundation
Tinkers Mechworks
Witchery


The fact that it's caused by loaded chunks in the Nether (once all players have left) rapidly loading/unloading in a loop makes me think it's be something like BuildCraft or a CoFH mod.
 
Last edited:

tfox83

New Member
Jul 29, 2019
1,588
0
0
Yea I'm leaning on it being one of those as well, I'll do some testing tomorrow and post what I find.
 

Rebirth Gaming

New Member
Jul 29, 2019
360
0
0
Just a heads up, stardustrider, we don't have Buildcraft in our pack, so that might not be the cause if we are having the same issue.

This may be related: https://github.com/SleepyTrousers/EnderIO/issues/1899

Next time my server's nether tps drops, I will run a cofh killall on wither and regular skeletons and take note of how many. I doubt it's related, because I don't think my players are placing spawners in the nether. Although, I could be wrong... that or dungeon pack is generating them.
 

stardustrider

New Member
Jul 29, 2019
13
0
0
Just a heads up, stardustrider, we don't have Buildcraft in our pack, so that might not be the cause if we are having the same issue.
My bad, all I did was search for Buildcraft and when it found it, I didn't notice that it was just the MFR BC compat module.

I don't think it's that, as that's mob spawning, rather than chunk unloading/reloading. I can sit in the Overworld (having just been to the nether) and watch the chunks refresh rapidly via the /chunkloader window and it's that fast it looks like z-fighting. I'm starting the process of elimination now, and starting with the CoFH mods.
 

tfox83

New Member
Jul 29, 2019
1,588
0
0
My bad, all I did was search for Buildcraft and when it found it, I didn't notice that it was just the MFR BC compat module.

I don't think it's that, as that's mob spawning, rather than chunk unloading/reloading. I can sit in the Overworld (having just been to the nether) and watch the chunks refresh rapidly via the /chunkloader window and it's that fast it looks like z-fighting. I'm starting the process of elimination now, and starting with the CoFH mods.
Awesome! Please let me know what you find, I am going to work on this in a few hours also
 

stardustrider

New Member
Jul 29, 2019
13
0
0
Progress! ...It's got nothing to do with CoFH whatsoever, or the mods that depend upon any of its mods.

Agricraft
Bibliocraft
Big Reactors
Blood Magic

Blood Utils
Sanguimancy
CoFHCore
CoFHLib
MiscMFRCircuits
NetherOres
OpenModularTurrets
Solarflux
SimplyJetpacks
ChickenChunks
ComputerCraft
FastCraft
Forbidden Magic
Jabba
MineFactory Reloaded
MobiusCore
Opis
Pam's Harvestcraft
Redstone Arsenal
Tinkers Construct
Thaumic Tinkerer
Thermal Dynamics
Thermal Expansion
Thermal Foundation
Tinkers Mechworks

ExtraTiC
IguanaTinkerTweaks
TiCTooltips
Witchery






(Rather than repeatedly posting progress as I check each mod, I'll just edit this post)
 
Last edited:

MrDlor

New Member
Jul 29, 2019
75
0
0
You can also cross out Opis since we have the issue without even having the mod on the server.
 

stardustrider

New Member
Jul 29, 2019
13
0
0
I've added mods I've disabled along the way that were child mods or had mods from the original list and dependencies. Also a few others that I've disabled as a hunch.
 
Last edited:

stardustrider

New Member
Jul 29, 2019
13
0
0
Rolling back to the previous versions of MobiusCore (and Opis) fixes the problem, at least until a new version is released.
 

tfox83

New Member
Jul 29, 2019
1,588
0
0
Rolling back to the previous versions of MobiusCore (and Opis) fixes the problem, at least until a new version is released.
Yea I tested that as well, ProfMobius told me he was looking into it so I will give it another couple days before I roll back, thankfully the current recommended build of Infinity isn't affected.
 
  • Like
Reactions: Rebirth Gaming

Rebirth Gaming

New Member
Jul 29, 2019
360
0
0
That's actually what I did as well on our pack's server. However, there seems to be a weird thing happening when clients using the latest version run opis while on a server with the previous version. It only affects the client after they run /opis - the get a fatal error and kicked from the server, and can't reconnect until they restart the client.

Not that big of a deal, considering only server admins run opis anyway, but I figured I'd give the heads up. It's better than having no opis at all and running into other lag issues, not being able to find out what they are. (Glares at Draconic chests.)

Anywho, ProfMobius has some quality mods, so I'm sure we will see a fix soon.