1.0.3: Buildcraft quarry glitch?

Discussion in 'FTB Presents Direwolf20 1.7.10' started by MindlessCrafter, Mar 7, 2015.

  1. MindlessCrafter

    MindlessCrafter New Member

    Version:
    1.0.3

    What is the bug:
    When using a build craft quarry my items are being tossed into the air and on the ground more than not. This is having tried using EnderIO's item transport conduits, and Build craft pipes.

    Simple system, quarry outputs through the top to EnderIO item transport conduit, inputs to a filtered trashcan (cobble, sand, dirt, gravel), then to a diamond chest.

    For Build Craft pipe its, gold out of the top to a diamond pipe, where its sorted for the same junk, then gold pipe to a diamond chest.

    Both systems have items tossed onto the ground with about a 1 in 3 to 1 in 4 success rate of sorting properly. Easier to see with Build Craft and just an assumption its the same for EnderIO. Dont think it will matter but the quarry is powered by a 3x3x3 Big Reactors basic at about 220 RF/t. Was using an Extra Utilities lava generator as a back up for a lead stone power cell for a while as well and had the same issues.

    Google only returns how to build a quarry, and wiki's.

    Mod & Version:
    direwolf20 1.04, minecraft 1.7.10

    Paste.feed-the-beast.com log:


    Can it be repeated:
    Yes. Used the same two builds, twice each.

    Known Fix:
     
  2. Dannyaaaa

    Dannyaaaa Member

    Try putting a chest on top of the quarry then piping items out of that.
     
  3. Trisscar

    Trisscar Well-Known Member

    Also did you have a wooden pipe before the gold one that was orientated the correct way? Or is that no longer a thing in BC?
     
  4. MindlessCrafter

    MindlessCrafter New Member

    Wood pipe out of a chest worked as a fix. Not sure why the EnderIO conduit was acting up, maybe they just dont play nice together.
     
  5. Trisscar

    Trisscar Well-Known Member

    Ahh, I think I know what's up here. So Ender IO conduits don't place in such a way that they automatically extract items. When they place, there are two parts to them, each with it's own UI;
    -The pipe in the middle, which when right clicked on will give you the status of itself in chat
    -And the "Conduit connecter"s, which are the gray plates that appear on the side of whatever the conduit has connected to. When right clicked, they open a UI that lets you change how they work, whether extracting, inserting, doing both as needed, or being completely disabled, at which point they no longer visibly connect to the machine or inventory.

    To get the Ender IO conduit to extract, you have to place it, right click on the conduit connecter, set it to extract mode, and tell it to work without a redstone signal. Which means you have to change the button with a redstone torch on it, and the title bar at the top of the UI.
     
  6. MindlessCrafter

    MindlessCrafter New Member

    You know i do always forget the redstone control on those things. That may very well have been it. I tend to notice the arrows being wrong but the redstone off always seems to get me. I may have to rebuild it with EnderIO and report back.
     
  7. MindlessCrafter

    MindlessCrafter New Member

    Ok i actually tracked this glitch down a bit better. Sadly i had to do it in my test world because a mystcraft age decided to corrupt the game where it had been happening. It is however repeatable. What i found was that any time ANY EnderIO conduit is attached to the quarry, it causes the contents to fly out of the top despite collecting 60-75% in the pipe network. I hooked a tesseract to the the side of a quarry and ran power through that to start, everything worked fine and the quarry collected everything into the buildcraft pipe network, no chest on top needed. The second i connected power with an EnderIO conduit, contents went flying. As soon as i disconnected the cable the quarry went back to functioning perfectly. So it would seem that enderIO conduits and the buidlcraft quarry simply do not like each other. I also found that even the redstone cable, placed in an adjacent square while it does not connect to the quarry, also causes the glitch.

    So it would seem it wasnt just me derping on the settings, there is actually an issue.
     
  8. asiekierka

    asiekierka Over-Achiever Mod Developer

    Yes, this is a bug in BuildCraftCompat, very specific to how we did our Ender IO integration. The workaround is to make sure you always connect power and item conduits in the same conduit, we'll fix it ASAP (but all the code is primed for BC 7 now, so it'll still take a while).
     
  9. MindlessCrafter

    MindlessCrafter New Member

    Thanks for the information Asiekierka, i hadn't tried running both conduits in the top, I've always just had power in the side. I also tried just having the item conduit out of the top, with power from a tesseract and that set up worked fine as well. It really is just a side and bottom connection issue. Knowing that i can just power through the top makes the early game a bit easier though since im not likely to have tesseracts lying around when running a buildcraft quarry.

    As for the the stone buildcraft pipe. I wasn't have any issues in my test with it being to slow. Now i only had two magmatic dynamos fully upgraded powering the quarry, and they seemed stuck at about 480 rf/t (960 rf/t total). The max they should reach is 1280 rf/t. I don't know enough about buildcraft quarrys to know if it was topped out on speed or not but the stone kept up just fine. I will say i only had one segment of it coming out the top, then a diamond pipe sorting, one to a void pipe, the other to the chest via stone of about 3 to 4 segments.

    As for the topic as a whole i think its been nailed, and a fix is coming. Plus several work arounds that work well have been mentioned. So i think im done experimenting with this. Thanks to everyone for there input and help, great community i will defiantly stick around.
     
    zBob likes this.
  10. cpy

    cpy Active Member

    Nobody will ever fix this bug?
     
  11. Scottly318

    Scottly318 Well-Known Member

    Considering that A: this is a yr old B: it's best to create your own thread and C: there are no further updates to the pack iirc the chances are pretty nil
     
    mc.crab likes this.

Share This Page