1.0.2: Tconstruct paper tool rod w/flux capacitor

Discussion in 'FTB Presents Direwolf20 1.7.10' started by john#33, Nov 28, 2014.

  1. john#33

    john#33 New Member

    Version:
    1.0.2

    What is the bug:
    Any Tconstruct pickaxe with a paper tool rod will not be able to take a flux upgrade

    Mod & Version:
    Tconstruct 1.7.1c

    Paste.feed-the-beast.com log:


    Can it be repeated:
    Create a new creative world, try to add a leadstone energy cell (or hardened flux capacitor) to a pickaxe with a paper tool rod

    Known Fix:
     
  2. Trisscar

    Trisscar New Member

    Related note; I have been unable to add full modifiers to certain TC tools, and it seems to happen after I fully upgrade them with redstone. For example, my manuyllyen-head/paper binding/green slime handle pickaxe only has moss and redstone on it, because it refuses to accept anything else now.
     
  3. RadioactiveSand

    RadioactiveSand New Member

    Not a bug but poorly documented feature. TiCo items have to have at least 1k durability to use a flux modifier, more if you want to use a higher tier of flux cell/capacitor.

    How much redstone did you put on it? If you've got 150 and 1 moss you've used your 4 base modifier slots.
     
  4. Trisscar

    Trisscar New Member

    What. Is that a change from the previous version? I don't seem to remember that being a thing before.
     
  5. itanshi

    itanshi New Member

    Yes, its a balance update, I guess.
     
  6. FInaldeath

    FInaldeath New Member

    Don't bother putting redstone on your tools anymore, just make the new glove and toss a bunch of it on there and it will work for all your tools and if you want a slower tool (for whatever reason) you don't need a second one you just remove the glove. The glove comes with 4 modifier slots and as far as i know only redstone works on it so you can make pretty much any tool ridiculously fast with it and use the tools slots for stuff like fortune and 3 moss or flux and something else.
     
  7. Evillevi

    Evillevi New Member

    Glove? Is there any docementation for Tcon 1.7 since I seem to be missing out on a few things
     
  8. SolManX

    SolManX New Member

    The glove is mentioned in one of the TiC books - but not much detail. Think I'm going to play with that!
     
  9. itanshi

    itanshi New Member

    I found it has 5 modifier slots :D. Pretty neat item. With a decent cobalt pick and sigil of the fast miner, I can nearly instant mine stone while flying.
     
  10. FInaldeath

    FInaldeath New Member

    I have an alumite shovel with the glove fully upped with redstone and digging up deserts is hilariously fast. I am so glad he added the glove since redstone is used alot and using multiple stacks on every tool is tough.

    Also to everyone in the thread, check out the new tinkers clothing as well. The traveler's clothing is pretty cheap and gives some nice early game bonuses like fast swimming, step assist, jump assist, pretty much all the fancy armor abilities. Not the best protection in the world but for how cheap it is, it is really nice early armor.
     
  11. Trisscar

    Trisscar New Member

    Can you apply any mods to the rest of the Traveller's gear? I've been attempting to and haven't found anything it will take, though i hadn't tried the gloves yet.
    Also I can't seem to find a material to fix the wings with, tried leather, gold, bronze, and ender pearls.
     
  12. FInaldeath

    FInaldeath New Member

    Look inside the first tinkers book, the armor has it's own mods, none of the tool mods work on the armor. As for repairing, i have no idea i have just tossed moss on it all and not have to worry about it. An easy way to get mossy stone early on if you cant find a dungeon is to craft a bucket of water with a piece of wheat and a cobble stone, you do get the bucket back so don't need to worry about that.
     
  13. Trisscar

    Trisscar New Member

    Ahhh, ok. I was expecting the mods to be in Materials v2, but this works. XD
    So I've done just about all of the possible mods now, but the stealth one won't apply to the vest, even if I go into creative, get a fresh one, and try every type of invis potion one after another. The book also says that I need to apply it in a tool forge, but that doesn't have enough slots for the all items I need to apply at once.
     
  14. FInaldeath

    FInaldeath New Member

    You are probably out of mod slots, stealth does indeed work as that was the only one i put on mine. Do it in a regular crafting bench, it is either a typo or the forge needs to be updated to support the gear.
     
  15. Trisscar

    Trisscar New Member

    If I'm out of mod slots then it's impossible to apply, since I tried it with a fresh, unmodded vest. I also tried it in a crafting station, which worked for the other mods that took more than three items to activate.
     
  16. FInaldeath

    FInaldeath New Member

    Worked fine in a world i started in 1.0.1 and a world i made in 1.0.2. Either you are doing something wrong that you aren't saying or you are getting some bizarre bug that no one else seems to have.
     
  17. Trisscar

    Trisscar New Member

    One that no one else has yet reported, true. I will also note that I am having to go off of the pictures in the Materials v1 book, none of which are labeled, and only some of them are mentioned in the descriptions. Hence why I simply went into gamemode 1 to try all the different kinds of invis potions once I started having the issue.
    According to said book, the recipe is fermented spider eye, potion, eye of ender, golden carrot. Is this true among other versions as well?
     
  18. FInaldeath

    FInaldeath New Member

    No idea, the only non "mods" i put on the gear have been moss for repair, the ninja one and featherfall. Never bothered with the others since by the time i would be able to get the stuff like the potions i already upgraded the armor, that and i have never gotten into potion making.

    Several people have reported issues with modding tinker's gear and tools, but every one i have seen turned out them just doing it wrong or being out of upgrade slots or trying to put a conflicting upgrade on a tool like trying to put silky on a fortune pick or flux on a repair pick.
     
  19. Trisscar

    Trisscar New Member

    Extra note; Be careful when applying the Dodge (ninja ninja) augment to the vest. Not only does it seem to move the character's position when you equip it (meaning if you are on the edge of a block, it will push you off), But it also seems to tax the system a bit, causing minor lag. This is also addressed on the TC main bug reporting forum, so probably not something the DW pack is doing.
     

Share This Page