1.0.1: Direwolf20 1.7.10 Server Performance Issues

Discussion in 'FTB Presents Direwolf20 1.7.10' started by Vash3k5, Nov 19, 2014.

  1. Vash3k5

    Vash3k5 New Member

    Version:
    1.0.1

    What is the bug:
    I am trying to run the DW20 pack on a Dell Poweredge 2900. I am disturbed at the performance issues as when then server jar is running its utilization of the cpu is pegged at 100% and it never drops down even when there is no one in the server. Is anyone else having this issue?

    Server Specs:
    Operating System
    Windows Server 2012 R2 Standard 64-bit
    CPU
    Intel Xeon E5450 @ 3.00GHz
    Harpertown 45nm Technology
    Intel Xeon E5450 @ 3.00GHz
    Harpertown 45nm Technology
    RAM
    24.0GB FB-DDR2 @ 330MHz (5-5-5-15)
    Motherboard
    Dell Inc. 0NX642 (CPU1)
    Graphics
    Standard Monitor ([email protected])
    ATI video (Dell)
    Storage
    297GB DELL PERC 5/i SCSI Disk Device (RAID)
    464GB DELL PERC 5/i SCSI Disk Device (RAID)
    Optical Drives
    HL-DT-ST CDRW/DVD GCC4482 ATA Device
    Audio
    No audio card detected

    Mod & Version:


    Paste.feed-the-beast.com log:


    Can it be repeated:


    Known Fix:
     
  2. Henry Link

    Henry Link Popular Member

    The physical server specs should be able to handle the pack just fine. My questions would revolve around the OS, Java and the java arguments you are using to run the server. My server is running a little bit better hardware but I'm running Ubuntu and java 7 update 51.
     
  3. Vash3k5

    Vash3k5 New Member

    I initially setup the server with Ubuntu 1401 Server with J7 on it and iw as getting the same problem so i figured that it might run better Windwos. I did not change any of the java arguments as i just click the server.jar and let it run. I cant even see the java arguments that are set as default for the FTB server jar. This makes me believe that there is something there that is causing this problem because I am also having performance issue on my desktop with the same problem and I am using the FTB launcher.

    If you have any suggestions on new java args that would be great.
     
  4. Henry Link

    Henry Link Popular Member

    OK there should be a server.sh or server.bat file you run to launch the server. Both of those files are simple text files and can be edited. You might want to check them out and use them to launch the jar file. Should be something similar to the code below.
    Code:
    java -Xms4096m -Xmx4096m -XX:PermSize=128m -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -jar FTBServer-1.7.10-1231.jar nogui
     
  5. Vash3k5

    Vash3k5 New Member

    After adding that code, the server starts up much better but it still is consuming the cpu at 100%. I tried joining it and I could move 3 blocks without lagging back to start position and the chunks take a long time to load
     
  6. Henry Link

    Henry Link Popular Member

    The last thing I can suggest is disabling Aroma backup and Aroma core. I've heard that those can cause issues on servers. I don't have 1st hand knowledge of this one though. I disabled them before I even ran the server the 1st time because I use a Ubuntu bash script for my backups.
    Also, I'm sure you are on the 64 bit version of java and not the 32 bit. The pack doesn't run well on 32 bit. I only mention this because I didn't see it listed in any of your previous posts.

    Out of curiosity what is the actual RAID configuration? How many physical drives and how are they setup? I would recommend a raid 0 for a few of the hard drives to increase the speed and configure the remainder for raid 1 or raid 5. Use the raid 0 for the OS and FTB with some type of backup to the raid 1 or raid 5 drives. I don't have enough drives on my server for local backups so I actually backup my server to dropbox.

    Also, I looked up the CPU on Intel's website. It is quite old at this point and doesn't have hyperthreading. Not sure if that could be an issue.
     
  7. seriousvern

    seriousvern New Member

    your issue is most likely because of the ram speed causing your cpu to work harder then it should. 330mhz ddr2 is not really recommended for something as intensive as modded minecraft
     
  8. Vash3k5

    Vash3k5 New Member

    Its not actualy 330mhz its 666mhz. Speccy reports it as 330 becuase its dual channel memory. As far as Henry's comment, The drives are configured at 2 [email protected] Raid 0 and 2 300Gb @ Raid 0+1. Minecraft is on the first set of drives. The CPUs dont have hyper threading because when I originally purchased the machine, it was GEN I machine and it only had 2.1 Ghz cpus on it, I did an upgrade to GEN III for the better cpus. Nothing else is running on it currently, I do run an Arma3 server, Kerbal Space Program MP server, FS13 server, PLEX with Sickbeard,(runnin in Hyper-V) but durring the setup for MC, I would shutdown everything. So MC is the only thing running.

    All of witch, on a busy day, I would only reach about 50% utilization on the cpus
     
  9. Henry Link

    Henry Link Popular Member

    At this point it has to do with something in the hardware. That server is at least 7 years old and heavy FTB packs are very CPU/Memory intensive due to the way Java and minecraft work. I know my server is running Zeon E3 processors at 3.4 GHz with DDR3 memory and it doesn't have any issues keeping up and can even run two FTB packs on it simultaneously.
     
    Last edited: Nov 21, 2014
  10. Vash3k5

    Vash3k5 New Member

    Sigh.
    I don't understand this because the machine i was running this pack on was an ancient dell pe 1400 and it ran percectly on it.
     
  11. Vash3k5

    Vash3k5 New Member

    Ok after some research I have figured out what the problem is. When you use the -Xms4096m -Xmx4096m java ticks to set memory usage, because I was using x64 of java, you have to change that from -Xms4096m to -Xms4G to denote java to use 4gb of memory as the -XmsXXXXm only work with memory sizes up to 1gb maybe 2. Once I made that change and removed Aroma Backup, the service Idles at 0% cpu and with 10 players is hovers at ~50%.
     
  12. blubbo

    blubbo New Member

    I'd hazard a guess that this part is the real culprit, not the java settings.
    Next time I'd recommend using Visual VM (or equivalent) instead of fumbling around in the dark changing settings. ;)
     
  13. Vash3k5

    Vash3k5 New Member

    Aroma was contributing to the problem. On my desktop I removed aroma backup from the pack when I first downloaded it and i was gettign the same issues, when i changed the ticks to 4G intsead of 4096m, minecraft smoothed out and runs with 600fps with no chunk lag. I found the Java tick info from Oracle's website.
     
  14. Eyamaz

    Eyamaz New Member

    Link? I would like to see this documentation.
     
  15. Vash3k5

    Vash3k5 New Member

  16. Yaeger

    Yaeger New Member

    According to their specs of the -Xms option:
    Format: -Xms<size>[g|G|m|M|k|K]

    I don't see any reference to particular numbers. I wouldn't use their examples as a specification of maximum sizes.

    On my machine, -Xmx4096 works fine.
     
    Eyamaz likes this.
  17. Vash3k5

    Vash3k5 New Member

    Using the example Oracle game.
    I changed my lines to -Xms2G -Xmx4G and now the machine runs like a champ. the effect was more profound on my desktop.
     
  18. Eyamaz

    Eyamaz New Member

    The documentation you linked has no information or proof of what you claim and I've never seen a difference in profiling.
     
  19. try disabling aroma backup. worked for me..
    edit: sorry, am blind..
     

Share This Page