Closed 1.0.0: Buildcraft and Railcraft worldgen issues

Discussion in 'Infinity Evolved 1.7.10' started by Bitty, Feb 6, 2015.

  1. Bitty

    Bitty New Member

    Version:
    1.0.0

    What is the bug:
    Setting up a new server, using the pregenspawn command to get things rolling. Getting many, many of these errors:

    [06:15:52] [Server thread/ERROR] [FML/]: Exception caught during firing event [email protected]dd:
    net.minecraft.util.ReportedException: Exception getting block type in world
    at net.minecraft.world.World.func_147439_a(World.java:354) ~[ahb.class:?]
    at buildcraft.energy.worldgen.OilPopulate.isOil(OilPopulate.java:259) ~[OilPopulate.class:?]
    at buildcraft.energy.worldgen.OilPopulate.isOilAdjacent(OilPopulate.java:294) ~[OilPopulate.class:?]
    at buildcraft.energy.worldgen.OilPopulate.setOilWithProba(OilPopulate.java:309) ~[OilPopulate.class:?]
    at buildcraft.energy.worldgen.OilPopulate.generateSurfaceDeposit(OilPopulate.java:233) ~[OilPopulate.class:?]
    at buildcraft.energy.worldgen.OilPopulate.generateOil(OilPopulate.java:166) ~[OilPopulate.class:?]
    at buildcraft.energy.worldgen.OilPopulate.populate(OilPopulate.java:65) ~[OilPopulate.class:?]
    at cpw.mods.fml.common.eventhandler.ASMEventHandler_645_OilPopulate_populate_Pre.invoke(.dynamic) ~[?:?]
    at cpw.mods.fml.common.eventhandler.ASMEventHandler.invoke(ASMEventHandler.java:54) ~[ASMEventHandler.class:?]
    at cpw.mods.fml.common.eventhandler.EventBus.post(EventBus.java:138) [EventBus.class:?]
    at net.minecraft.world.gen.ChunkProviderGenerate.func_73153_a(ChunkProviderGenerate.java:377) [aqz.class:?]
    at net.minecraft.world.gen.ChunkProviderServer.func_73153_a(ChunkProviderServer.java:279) [ms.class:?]
    at mcp.mobius.pregen.exec.PregenExec.exec(PregenExec.java:139) [PregenExec.class:?]
    at mcp.mobius.pregen.TickHandler.foo(TickHandler.java:16) [TickHandler.class:?]
    at cpw.mods.fml.common.eventhandler.ASMEventHandler_450_TickHandler_foo_ServerTickEvent.invoke(.dynamic) [?:?]
    at cpw.mods.fml.common.eventhandler.ASMEventHandler.invoke(ASMEventHandler.java:54) [ASMEventHandler.class:?]
    at cpw.mods.fml.common.eventhandler.EventBus.post(EventBus.java:138) [EventBus.class:?]
    at cpw.mods.fml.common.FMLCommonHandler.onPostServerTick(FMLCommonHandler.java:247) [FMLCommonHandler.class:?]
    at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:590) [MinecraftServer.class:?]
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:427) [MinecraftServer.class:?]
    at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685) [li.class:?]
    Caused by: java.lang.RuntimeException: Already decorating!!
    at net.minecraft.world.biome.BiomeDecorator.func_150512_a(BiomeDecorator.java:97) ~[aia.class:?]
    at net.minecraft.world.biome.BiomeGenBase.func_76728_a(BiomeGenBase.java:339) ~[ahu.class:?]
    at net.minecraft.world.gen.ChunkProviderGenerate.func_73153_a(ChunkProviderGenerate.java:421) ~[aqz.class:?]
    at net.minecraft.world.gen.ChunkProviderServer.func_73153_a(ChunkProviderServer.java:279) ~[ms.class:?]
    at fastcraft.a.c.a(F:84) ~[fastcraft-1.19.jar:?]
    at fastcraft.Hooks.r(F:139) ~[fastcraft-1.19.jar:?]
    at net.minecraft.world.chunk.Chunk.func_76624_a(Chunk.java:1050) ~[apx.class:?]
    at net.minecraftforge.common.chunkio.ChunkIOProvider.callStage2(ChunkIOProvider.java:52) ~[ChunkIOProvider.class:?]
    at net.minecraftforge.common.chunkio.ChunkIOProvider.callStage2(ChunkIOProvider.java:12) ~[ChunkIOProvider.class:?]
    at net.minecraftforge.common.util.AsynchronousExecutor.skipQueue(AsynchronousExecutor.java:344) ~[AsynchronousExecutor.class:?]
    at net.minecraftforge.common.util.AsynchronousExecutor.getSkipQueue(AsynchronousExecutor.java:302) ~[AsynchronousExecutor.class:?]
    at net.minecraftforge.common.chunkio.ChunkIOExecutor.syncChunkLoad(ChunkIOExecutor.java:12) ~[ChunkIOExecutor.class:?]
    at net.minecraft.world.gen.ChunkProviderServer.loadChunk(ChunkProviderServer.java:126) ~[ms.class:?]
    at net.minecraft.world.gen.ChunkProviderServer.func_73158_c(ChunkProviderServer.java:101) ~[ms.class:?]
    at net.minecraft.world.gen.ChunkProviderServer.func_73154_d(ChunkProviderServer.java:199) ~[ms.class:?]
    at net.minecraft.world.World.func_72964_e(World.java:419) ~[ahb.class:?]
    at net.minecraft.world.World.func_147439_a(World.java:345) ~[ahb.class:?]
    ... 20 more
    [06:15:52] [Server thread/ERROR] [FML/]: Index: 3 Listeners:
    [06:15:52] [Server thread/ERROR] [FML/]: 0: NORMAL
    [06:15:52] [Server thread/ERROR] [FML/]: 1: ASM: [email protected] generate(Lnet/minecraftforge/event/terraingen/PopulateChunkEvent$Pre;)V
    [06:15:52] [Server thread/ERROR] [FML/]: 2: ASM: [email protected] generate(Lnet/minecraftforge/event/terraingen/PopulateChunkEvent$Pre;)V
    [06:15:52] [Server thread/ERROR] [FML/]: 3: ASM: [email protected] populate(Lnet/minecraftforge/event/terraingen/PopulateChunkEvent$Pre;)V

    Mod & Version:


    Paste.feed-the-beast.com log:


    Can it be repeated:
    Just use pregenspawn with a large enough value to have it create the entities in question.

    Known Fix:
     
  2. mti_

    mti_ New Member

    I experienced errors while doing pregen.
    What fixed it for me is have the server idle for a minute or two after generating the world in the first place and once TPS have calmed down a bit I could pregen w/o getting any errors. It was railcraft oil being the problem tho.
    (Also I have noticed that volcanos can sometimes only spawn in one half when pregen'd)
     
  3. tfox83

    tfox83 New Member

    Sounds like your server may have a weak CPU and is under a lot of stress during pregen causing volcanoes to not generate properly.
     

Share This Page