Search results

  • FTB will be shutting down this forum by the end of July. To participate in our community discussions, please join our Discord! https://ftb.team/discord
  1. J

    More news about FTB's Future. (Important announcement)

    So I was on a logmcdw20 server and it says I have to be on 1.5.2 launcher I think, but no matter if I update, I'm still 1.4.7, what do I do?